footnotes disappear

I cannot find if this topic is covered elsewhere, apologies if it is.

I have several web archives that I have converted to text using scrivener 2.0’s built in function. The reason for the conversion is because I want to annotate them with comments and footnotes as part of my research method.

When reading through these research texts, I enter full screen mode and have the inspector panel open with the comments & footnotes pane showing.

  • I enter a footnote on part of the text and type my note.
  • I read further and make a new footnote and as soon as I press the button to make a new footnote - the text that I typed into the previous footnote disappears. The footnote itself still appears in the text (the hilight or whatever) and the box in the footnote pane is still there - just empty.

This is quite a bit frustrating.

Other than that I am loving everything else in 2.0. Productivity is up up up and writing is a dream. zzzzzz :slight_smile:


Are you trying to add another footnote to the same bit of text? Because if so, it will overwrite the old one (although you can just hit Undo once the focus is back in the text to undo the change). Obviously you can’t have multiple footnotes at the exact same point - make sure you are clicking somewhere else in the text.

Mind you, this shouldn’t be happening - if you go to make a footnote at the same point, the footnote should just be selected for editing rather than overridden (unless you made a comment over a footnote).

Could you please provide the exact steps I need to reproduce this?


All the best,

Hi Keith,

thanks (as usual) for the prompt response.

I am not trying to add a new footnote to the same bit of text. I am trying to add a footnote to an entirely different part of the document. I click elsewhere in the text and then click on the ‘add footnote’ icon in the inspector window I have open.

An interesting point: I have just realised that if I use the shortcut to add a footnote (ctrl-command-8) then it does not delete the text of the previous footnote. This only happens if I click on the icon in the inspector window. Also this behaviour only happens if I am in full screen mode.

Here are the steps I go through:
1 - import page into binder (research folder) by dragging link there eg :
(I drag the icon next to the url from safari - it then imports the page - I assume this is correct practice as I read it on the forum somewhere)

2- I select the document in the research folder and convert it via the menu: Documents / Convert / web archive to text.

3 - I load document into full screen mode and add the first footnote via the icon in the inspector window

4 - add next footnote to new section of text via the icon and poof… the text in the first footnote vanishes.

I just conducted another little experiment. After typing some text into the footnote and then clicking elsewhere in the inspector window and then adding another footnote to the document - the text of the previous footnote then remains in place.

I hope I am making sense.
In all honesty since wrapping my head around the shortcut I am now going to use that all the time and not the icon… but guess its still something you would like to know about :slight_smile:

Thanks for the help!

Hmm, I just tried exactly that, and it worked fine - but this may be down to fixes I have made since. Could you please check the About panel and tell me the build number? (Choose “About Scrivener” from the “Scrivener” menu and then look for the number - 6000 and something - after the “2.0” towards the bottom.)



it says Version 2.0 (6000)

I guess I am missing the ‘and something part’ :slight_smile:

Yup yup yup…

Just downloaded Scrivener again (build 6218) and replaced the older version and now the footnotes persist even when I abuse the icon.

Thanks Keith!

Ah, great! Sorry, all these changes will get rolled into an official 2.0.1 update soon - I’ve just uploaded some interim builds so that users can test out whether certain bug-fixes have worked. Good to know this one is squashed!

All the best,