Footnotes inside quotation marks

For some reason my footnotes are now appearing inside quotes when the quote ends a sentence.


I want my footnotes outside the quotation marks as in standard American style. Any ideas?

To clarify a bit, let’s say I have the following piece of text I want to footnote:

“This is the piece of text,” he said, “I want to footnote.”

If I highlight a chunk of the text, including the ending quotation mark, then append an inspector footnote, the mark for the footnote will appear after the quotation mark, like I want it to. If I just hit the button for a footnote with the cursor sitting after the quotation mark, the mark for the footnote will appear between the period and the quotation mark (like this:…footnote.^") That’s not what I want.

The option to terminate footnotes before punctuation is not checked so I don’t think that’s the issue.

What I wonder is whether this has something to do with British vs American style where the period would be outside the quotation mark. But I don’t see any option to switch between US/UK English, only English.

I previously used Scrivener on a Mac and didn’t have this problem, so there must be a way to fix it. Any suggestions would be much appreciated.

This is to do with how the algorithm is selecting the word and punctuation for the footnote. When automatically selected, the note applies to the closest word and one punctuation mark, placing the footnote between the period and the quotation mark. If the quote mark immediately followed the word, it would be selected with the word, placing the footnote outside it.

We’ll look at how to refine this behaviour to cover cases like this to place the footnote marker outside the quote, but currently the solution is simply to select the section deliberately. You could do this quickly with the keyboard using Shift+LeftArrow (or Ctrl+Shift if you wanted to back up and select the whole word). You could also use inline footnotes rather than inspector.