Footnotes next to each other

I’m trying to like Scrivener but find it much more difficult to use than Flare, Framemaker, Docbook, DITA. Especially difficult are two or more footnotes next to each other (which even Word can handle). When I create an inline footnote, there doesn’t seem to be a way to get out of it to type something beyond the footnote. Trying to add an additional footnote just brings me back to the previous footnote, so I can’t have one insertion point and two footnotes or one immediately after the first. I’ve tried regular and inline footnotes and both seem to have this flaw. I am relatively new to Scrivener, so perhaps it is user error, but if so, it is not intuitive. Is there a solution?

When you’re done writing the content of the (inline) footnote, hit F (or click on the corresponding menu item: Insert → Inline Footnote, which will have a checkmark in front of it), that will exit the footnote. Press Space. Start another footnote (or other text). And so on.

There doesn’t seem to be a way to insert a second footnote immediately adjacent to the first. Is putting a space between them the only way?

As far as I can tell, yes. Tried to remove the space after the fact and both footnotes merge into one. (EDIT: It works for non-inline footnotes, though.)

2022-11-10 20_24_26-Scrivener

2022-11-10 20_25_37-Window



Try that with inline footnotes.

Inline footnotes don’t work if they are adjacent. You need a space or they get merged as one.
You could insert a special character instead of a space, and have that character automatically removed at compile. (Say this one: ₻ as you don’t risk having used it elsewhere – for something else – in your project. – Unless that symbol actually means something to you. But I’m sure you get the idea, pick a special character that won’t be used for anything other than this.)

Then in auto-replace of the compiler, or of the compile format, have it be replaced with nothing.

P.S. I am running the Windows version. (I don’t think it matters here, though.)

I know. But it’s funny, I completely forgot about this project setting (the footnote marker). Glad you posted the screenshot.


Thank you for the project setting tip. Unfortunately without a space I cannot insert consecutive footnotes without a space between them. Maybe it is a Mac thing. I got spoiled with LaTeX, which not only handles endnotes/footnotes well but even can figure out consecutive numbers and make them something like "[3-5,7,8].

But… question:
How do you plan on having two consecutive footnotes without them appearing in the final as
12, 23 or 34 ?

Scrivener handles LaTex


Adjacent comments (like a lot of other things) act as one because they’re implemented in terms of styles behind the scenes, and that’s how styles behave. Or so I’ve been led to believe.

Thank you for the replies. I tried adding superscript commas between footnotes, but they did not align properly so I had to change that to a non superscript comma with two baseline shifts upwards. I was hoping the compiler would handle consecutive footnotes, but probably I should use project settings for “Fn” and manually add the square brackets and non elevated commas manually.

By the way, if you create a non inline footnote at the end of a word, is there a way of changing the highlight to several words or a sentence after the fact? If one highlights the words first, it works, but how do you change this later?

Right-click in the footnote:

(P.S. You can’t see the blue underline under “example” because my corrector is set to French and reports that word as being misspelled.)

Thank you all for your replies. It is not very intuitive but will be much easier to work with.

1 Like

One problem. When compiled, the footnotes come over as "Fn"superscript-number. Is there a way of omitting the “Fn” in compiling?

It shouldn’t be there.
My thought is that you misused the footnote marker or something.
Do you actually have that “fn” in your editor ?

Technically, the footnote marker gets replaced with the superscript footnote reference number.
If it is still visible after compile (and is wearing the superscript number), that means you did something that led Scrivener to think it is part of the text (not a marker).
(Do not modify the marker in the editor)

2022-11-11 09_56_28-Window

. . . . . . .




. . . . . .



I am the one who customized my marker to have brackets (I don’t remember what the default was). Your marker can be anything you like. But never modify it in the editor afterwards, else the auto-replace won’t recognize it at compile.

P.S. While I was at it I tried compiling two consecutive footnotes, without a space in-between, using the footnote marker:
It doesn’t work. It is all messed up at compile.
You’ll have to figure out some other way to reference those.
Which I don’t recall having ever seen done anyways. Not sure that it is such a great idea. (Just sayin’)


The default footnote marker is an asterisk.



1 Like

Unfortunately, the issue persists. I wish I could add a image link to show the problem, but I can’t attach a jpg to this post. ( I get the “sorry, you can’t embed media items in a post” message) Perhaps the project somehow got corrupted. I also see that unlike the windows version, I can’t set footnotes to indent to text in the mac version under compile settings. Perhaps this isn’t the right software for my type of work.

I don’t know what to tell you, other than:
there is nothing I did here with the Windows version that technically you can’t do using a Mac.

I’m not sure I get what you mean.