Footnotes problems in compiled document


I have some problems with footnotes when I compile in .doc. I guess there are some settings I change tweak inside MS Word to fix those but I just can’t seem to find them so here I am.

First problem: some footnotes are vertically cut in half. See:

My current fix is just to “add space after the paragraph”, but it’s not exactly a solution because if I move stuff around and this footnote happens to not be the last on the page, I get an annoying white space between two footnotes.

There must be a way to avoid this?

Second problem: some footnotes are split on two pages. See:

I never get that on Word documents created by myself, only on documents created through Scrivener’s compile. What settings do I have to change in Word or in Scrivener to get them back on a single page?

Thank you in advance for your help,


Oh I have found the answer to the second problem: in the Paragraph styling menu, just check the “Keep lines together” option.

It would be nice to get this option in Scrivener’s compile menu though instead of having to do it manually. :slight_smile:

Still looking for an answer to the first problem. Thanks in advance!

Oh noes, third problem: I just noticed that when there is no punctuation at the end of the quote, Scrivener puts the small superscript number outside the closing quotes! :frowning:

In French (in my field at least), the number always goes inside the quotes (before the final punctuation if there is one, but still inside the quotes if there is none).

Any way I can get this to export correctly?

EDIT. Argh, there are even more problems with the footnotes. What’s going on?! Why is the superscript number not always where I put it in Scrivener?

A fourth problem: sometimes the footnote is called on a page, and then the note is not at the end of that page, but at the end of the next! How can I fix this? What’s going on here? Why does Scrivener’s compile has so much trouble exporting footnotes correctly?

First off I’d try compiling to RTF rather than DOC, to avoid the extra conversion. Scrivener has a few options for converters to the DOC format, so what you get will be a little different with each, but since you can open RTF in Word anyway, there’s no reason to do the conversion with third-party tools.

That might take care of the cut-off problem and maybe the problem with the footnote appearing on the incorrect page. Scrivener just marks the footnotes in the RTF code and it’s up to the word processor to interpret that and handle the layout, so I’m not sure what might be misplacing it here. If the problem still occurs when compiling to RTF, could you send a sample project to AT literatureandlatte DOT com along with instructions to reproduce it, including what version of Word you’re using to check the file?

The footnote marker should be placed exactly where the inspector footnote link ends or where the inline footnote bubble begins. Selecting the text in Scrivener when creating the footnote will give you precise placement for the linked inspector notes. The algorithm for placing the inspector footnotes on unselected text (i.e. just based on the location of the insertion point) is determined in part by the setting in the Editor tab of Tools > Options, “Terminate footnotes and comments before punctuation”. Select that if you haven’t already, but still keep an eye on where they land if you create the footnotes without making a text selection first, to ensure that multiple punctuation marks or spacing hasn’t caused it to end where you don’t want it.

I’ll see about RTF tomorrow, but just a quick note about footnote marker: it doesn’t place the marker where the cursor is. See where my cursor is:

And see how the footnote is being generated—the marker is placed outside the closing quotes even though the cursor was inside it:

And I got the option you mention checked.

I just realized, though, that it works as intented when you SELECT the exact text first, as you mention. But why doesn’t it work also with cursor placement?

Thanks again. Gotta run now, but will report about the RTF tomorrow.

Ah, my mistake about the automatic placement; I’d been thinking about the quotation mark being outside the closing punctuation rather than inside. This is actually something I have some notes on from earlier, about how the algorithm works to identify the punctuation and place the footnote, but it’s rather complex handling and we weren’t able to do anything more with it at the time. I will make sure that we take another look at it for future refinements though. I don’t know if it’s ever going to be able to automatically cover every situation, though, given that there are multiple styles and different punctuation rules for different languages. Thus the safest method is still to just select the text yourself, or apply the footnote before finishing the closing punctuation.

Two years later, I was about to open another thread about this issue, and then I had a vague souvenir about doing it already. Seems like the image are missing in my original post, but here is the issue, that is still not fixed. Sometimes the footnotes are visually cut in half like this:

And I fail to find a logic to this. Sure, I can manually add a space after the problematic footnotes, but it doesn’t make any sense… And if I modify stuff earlier in the document, I have to remember to go back and remove that space.

By the way, I tried what was suggested: compiling in RTF instead of Doc. And it doesn’t have any effect.

Any idea what is happening here and what could be done to avoid it? I have a rather huge document, with tons of footnote, and I don’t want to do all this manually. This is really a deal breaker for me, but now seems like I’m stuck with it…

Thanks for any help.

I’m also still getting a lot of problems like footnotes ending on a different page than where the note is called (like the footnote appears on the next one). How can I adjust the settings in Word to correct that problem?

The problem of the footnote cut in half mentioned in my previous post is still an issue aswell.

Please help.

I agree it doesn’t make much sense! Do you have a sample project and compiled doc you could zip and attach or send to AT literatureandlatte DOT com? I’ve never seen another case of the footnote line being sliced like that, and being able to see it first-hand will help a lot with discovering the problem. What version of Word are you using to view the compiled document? Have you tried opening it in any other program?

Thanks for getting back to me. I’m away for a couple of days, but I’ll be sure to send you guys the project & compiled doc early next week when I’m back home. I haven’t tried opening the doc in another program, no. I’ll see what I can do. The other strange thing is the footnotes sent on the next pages instead of being at the bottom of the page where they are called…