Footnotes/TOC lost the hyperlink in compile when I switched formats

I am still having this issue, even though I double checked and confirmed this is NOT checked:

"In the right-hand panel of the main Compile screen, under the Gear icon, make sure “remove all hyperlinks” is not checked. "

Is this a bug in the Paperback 6x9 format? Or anything else I can do to fix it? It is a real hassle in proof reading and has persisted in all of my compiles since the format change. When I switch back to Paperback 5.06x7.81 and compile again the links work fine. However when switching back to 6x9 still the issue…and this is the format I prefer. (or let me know if there is another larger Paperback format - happy to try out another size as long as it is larger not smaller)

Please help :slight_smile:
Leslie

See prior post for more details: Footnotes/TOC lost the hyperlink in compile when I switched formats

Excerpt here:

I was using a compiler format that was an edited version of Paperback 5.06x7.81 and when I would compile to a PDF format the resulting document would have the footnote numbers as hyperlinks to the footnotes sitting in the Endnotes section. As I was proof reading, I could click on the footnote number, double check the footnote itself, then click on the endnote number and jump back to the point in the main text that I had been reading. This is my preference, yay!

However, I recently changed to a new format - an edited version of the Paperback 6x9. When I compile to PDF the resulting footnote numbers are no longer hyperlinks. Same with the Table of Contents, it no longer links to the Chapter from the listing in the Table of Contents.

Is there a setting I need to change to get these back? I tried reviewing all the settings in both formats to try to have them match the best I could, yet still having the issue.

(I am using Scrivener 3.1.2)

Thanks for any help or tips!

FRI MAR 15, 2019 12:44 PM POST

In the right-hand panel of the main Compile screen, under the Gear icon, make sure “remove all hyperlinks” is not checked.

Katherine
Scrivener Support Team
Online
User avatar
Leslie
Posts: 2
Joined: Fri Mar 15, 2019 11:28 am
Platform: Mac
Contact: Contact Leslie
DELETE POST REPORT THIS POST QUOTE
FRI MAR 15, 2019 2:56 PM POST

Confirmed. It has not been checked, and the issue is still there.

Any other suggestions?

Could you open a support ticket and send a test project that demonstrates this behavior, please? Put my name in the subject line to call it to my attention.
literatureandlatte.com/contact-us

You can email a project by using the File -> Backup -> Backup To command, and checking the box to create a ZIP backup.

Clearly there’s a difference in settings between the two Compile formats, but I’d need to actually look at them to see what it is.

Katherine

Have you tried just editing the format that works correctly to use the other page size?

Paper size is defined in the Page Settings tab of the Compile Format editor.

Katherine

Aha! Great idea! I updated the 5+/8+ format to match the 6x9 format page size and yes it works! I had made many other changes to that format so it took a little time to pick thru and get them all matching - but I think I have them all transferred correctly now. Yay!

If I find I need to go back to the Paperback 6x9 format that wasn’t working I will submit a support ticket as you note.

Thanks so much!!

Leslie