I’m still having a lot of problems with footnotes, which is a shame because my project lives and dies with them. Footnotes don’t show up for me at all when I compile .rtf files. PDF files do have them, but Scrivener doesn’t superscript them or denote in any way that they’re not just a number stuck in the text, and worse, if there’s something italicized in the footnote, it creates another footnote where the italicized text begins.

What are you using to open the RTF files in? Scrivener doesn’t actually do anything in regards to superscript and all that—this is up to the word processor displaying the footnote codes which are placed into the rich text file inline, much like you see them in Scrivener, except a whole lot messier. :slight_smile: When I compile as RTF with footnotes enabled in the compile options, I can open this file in Word and get footnotes looking just like they should.

Ah, that did make a difference; I was opening RTFs in Wordpad, but in OpenOffice Writer they format a lot better, thanks for the tip! Unfortunately, I still get multiple footnotes when something in the footnote is italicized, which is actually a bigger deal for me.

That’ll do it. As far as I know, there is no way to get real footnotes in WordPad. You would probably need to “flatten” them into formatted text to get them in. They wouldn’t be real footnotes, but at least they would look like them and be there. I’m not sure if flattening is a feature yet though.

Not to dismiss the possibility of a bug, but are you routinely italicising footnotes for a particular design purpose? If so, might be better to handle that sort of thing in post with a word processor style sheet, rather than adding your own formatting by hand on a one by one basis. If it is just something you do he and there for a particular type of footnote, then never mind all of that.

Well, the problem is that many of my footnotes have italicized sections to indicate the title of a book or movie, and pretty much all of them have a mention to one or the other. I don’t feel it is, in any way, unreasonable to expect that footnoted text behaves more or less similar to we’ve come to expect with normal formatting tools, except perhaps that it’s possibly smaller.

In any respect, it seems to me that this is clearly a bug; change from regular text to italics or bold or whatever should not trigger an entirely new footnote. When was the last time you read a footnote with “et al.” that wasn’t italicized? For that matter, wouldn’t you find “7 et al.” by itself a little confusing?

Oh, it definitely sounds like a bug. I wasn’t saying footnotes shouldn’t allow formatting. I was merely asking if you were italicising the entire footnote, every single one of them—as in that’s the way you like them to look. If so—I’d do that with stylesheets later on. Obviously, if you need to italicise a book title you should do so. :slight_smile:

Okay, it’s been over a month and several releases, but if anything, footnotes are working even worse that before. On the rare occasion when I can get them to show up, they appear as part of the sentence they accompany with no indicator that they’re a footnote. Am I missing something here? Can someone give me some pointers?

As I have to use footnotes a lot, it’s the first thing I check when a new beta version has been released. It seems they didn’t address this bug yet. I hope the final version will have a bugfree footnote option, otherwise it’s pretty useless for me.

Ehm, footnotes don’t quite work as expected for me as well, even in 0.20 – and I don’t use italics on mine. The behavior is basically erratic; numbering starts at 189, for instance, or a single footnote is pulverized into two or three. I tried compiling in both rtf and doc formats, and the results are consistently wrong in an inconsistent way.

Here’s hoping this is being addressed!

Okay, there’s a few things here. We will do our best to address as many of these issues as we can as soon as we can.