Force Click support to activate Lookup.

Currently have to disable Force Click in system preferences as it prevents easy access to dictionary lookup in Scrivener (2.7). As this is a system global option, sadly cannot disable it just for Scrivener, so loose the ‘hard push to lookup word definition’ in all application. The one app I’d really, really like this to actually work is Scrivener! For now, back to three-finger-tap in everything :frowning:

This has been requested before. But anyway, a big +1 for Scrivener support for this OS feature.

In the meantime, you can probably get bettertouchtool to do what you need (haven’t tried it, I used to love BTT but haven’t used it for the last year or so)… … trackpads/

Please explain, as I don’t understand the problem. Scrivener uses the standard OS X text system so gestures should be the same in the text area as in TextEdit.

Keith, with Force Touch if you force-click on a word you do get the “look up” floating window (Pages, Textedit etc in OS X 10.11), but this just doesn’t work in Scriv, the dev docs do seem to suggest force touch depends on new NSEvents properties that may not depend on the text system per se? … vent/stage

Nontroppo pretty much covered it. For some reason the text areas throughout Scrivener ignore Force Touch events. I’ve installed BetterTouch and macro’d Force Touch for Scrivener so that it triggers Lookup on ‘hard presses’ with the newer trackpads / MacBooks - that seems fine as a work-around, but I imagine as FT becomes more widely available it’s something that should be in the Scriv backlog :slight_smile:

And you say that you are seeing this work in TextEdit? I can get Force Touch to bring up look ups in Pages, but not in TextEdit. As Scrivener uses the same text engine as TextEdit, it should act the same in most areas (except where customised).

Yep, triggers the popup in TextEdit (OS X 10.11.1, 2015 MacBook) - force-click on any word causes popup to appear with dictionary/thesaurus. Bizarre if it’s a standard feature of the component/API scriv uses scratches head

Screen Shot 2015-10-29 at 00.54.17_SMALL.png

Works for rich text as well as plain text in TextEdit (V1.11)

Is there anything I have to enable? I just updated to 10.11.1 but that made no difference - force clicks do not bring up look-ups for me in TextEdit as they do in Pages. Weird. If they work in TextEdit for you, I’m not sure why they don’t in Scrivener, though, since it uses the same fundamental engine. I need to get it working in TextEdit to be able to test though - strange!

With this setting in trackpad prefs enabled (which I think it is by default on new macbooks, at least mine was):

I checked if textedit had any preferences for this (defaults read but there is nothing in there at all related to this. I didn’t see anything obvious on a google search tthat this is a common bug…

Ah, okay, I needed to change the setting from three-finger tap to force-click - possibly because I think I transferred data from an old machine, so the settings probably came across.

Anyway, looking at this, there’s nothing I can do about it for 2.x, I’m afraid. I found that force-clicking on words in 2.x does nothing, but force-clicking on words in an in-development, future release version of Scrivener works as expected, with look-ups coming up. As there are no significant differences in that aspect of the text system, I then ran a quick sample app with nothing in it but a vanilla text view, and that confirmed my suspicions - force-click look-ups only work in 64-bit apps. As Scrivener 2.x is 32-bit apps, they don’t work. (I don’t know why this should be, given that force-click can be used 32-bit apps; it seems to be a bug on Apple’s side.) For backwards-compatibility reasons, I can’t make 2.x 64-bit. The next major (paid) update is 64-bit, though (I spent a couple of months updating the code to make it so).

Sorry it’s not better news, but some time next year it will start working. :slight_smile: (Although work on the iOS version is now pushing that next major update back a bit…)

All the best,

Thanks for the investigation around this Keith.

There’ a solid (free) workaround via BetterTouch and always the built-in key shortcut, so it’s not end-of-the-world.

Still… I’m ready and waiting to pay for the mysterious and tantalising ‘Scrivener XX’ :smiley:

It requires using a corner, though, so your thumb needs to be in good shape. I wrote the BTT dev and he said he can’t yet make that option work allowing a force touch anywhere on the trackpad—has to be a corner for now.

So anyway, the news that Scrivener 3 might fix this whole thing is pretty exciting.