"Format As" field changing when compiling


I’m trying to compile an ebook, but whenever I select the cover image the “Format As” field changes from “E-Book” to “Custom.” Is there a way to keep it as “E-book,” or otherwise preserve that formatting and layout?

“Custom” just means that settings have been edited from the preset, in this case adding a cover image. All the other settings that are part of the “E-book” preset are the same. In short–don’t worry about it.

OK, but then when I compile it the file doesn’t have that formatting (paragraph indentations, etc.). Any advice for how I can preserve that, or add those in another way?

In the Mac version you can save these from the Format As menu with Manage Custom Preset Formats… . I do this for my all my Compile usages as the defaults are never right. I played around with the settings I wanted and then saved them so I was sure to get consistency later.

To save custom presets on Windows, you click the “Save Preset…” button at the bottom left and give it a name; it will then be available from any project via the drop-down menu, same as the defaults. Saving the preset won’t fix the problem described, though, since it would just be saving whatever formatting is already there and not working.

Does the “E-book” compile preset compile the way you’re expecting? Some formatting may not be coming through depending on what the e-reader supports. Also any documents marked to compile “as-is” would not take the formatting from the compile settings, although again with the limitations of what the devices support, it may not appear exactly as in the editor, either.