Format problem when writing Chinese script

Why do I use script mode and the dialogue and equal line spacing are not displayed correctly?

Hi.
It is hard to tell because 1) I don’t read Chinese, and 2) that is a screenshot of your compile output (rather than Scrivener’s editor).

Still, from what I can see : it is persistently your third line that is indented more to the left.
(Is that the problem ?)

Here is what I believe to be the explanation with this little information :
In script mode, for many of the different script elements, when you hit “enter”, it takes you from this script element to another.
Therefor creating the overall page formatting as set in the script settings panel.
image

Here you set what you want the next element to be :
image

And here you set the formatting for the different elements :
image

Click on a line that is not the way you expected/want it to be, and see if it is of a different element than the lines that you consider to be ok :
Inked2022-03-25 22_08_00-Window_LI

You can also change the element a line is wrongly assigned to, where I pointed my arrow.

Yes, I set it here, but on the MAC, it’s not as elaborate as it is on Win

In Chinese script, there is a problem with line spacing display. How to solve this problem?

屏幕快照 2022-03-26 上午10.10.08

Can you please better define the problem ?
What is it that is wrong to you in your first screenshot ?

Is it the double spacing ?
Or the absence of space between the lines ?

That is the spacing between the lines :
image

And that is the spacing between your paragraphs :
image
→ A new paragraph starts whenever you hit enter.

But those adjustments need to be done for the proper script element.
If, for example, the line displaying wrong is a “character” one, that is where you need to adjust it :
Inked2022-03-27 00_39_12-Window_LI

Click in the editor on a line that is formatted wrong to know what type of element it is of. And then make the adjustments for that one element.


The parameter adjustment of Mac version is double spacing, which can not meet the needs of Chinese script.


The correct format should be such spacing

You can adjust it as you wish.
Look up, I just told you how.

There is no way to fine adjust the line spacing under the Mac version. Is this a problem of software development? Thank you!

You mean you can’t set it to 1.5 ?

xx
Yes, the parameter here has been modified, and there is no response in the script.

你说得很对 …… 没办法!这是我设置的 (He’s right … it doesn’t work. These are my settings):

这个截屏, 左边可以看通常的例文,右边是剧本。两个都用1.2间距。(In this screenshot, on the left hand side you can see a chunk of normal text, on the right it is in Screenplay. Both use 12pt Songti SC with 1.2 pts interline spacing.)

我的脚本设置 (These are my Screenplay settings):
Screenplay.xml.zip (1.7 KB)

I don’t know if KB can do anything about the line-spacing not working in Screenplay format with Chinese. I don’t use any screenplay format, so I don’t know if there’s also a problem with other languages/scripts.

:blush:

Mark

Thank you for your reply. I found a way to import it into the MAC after setting it in the win version. There are still some small problems. It can be used for the time being.

Hi @wwchao1974,

Your English is better than my Chinese, I think! :laughing:

I joined in as soon as I had time, as I am a Mac-user working with Chinese. I help Chinese friends and former colleagues with Chinese → English and English → Chinese translation, but don’t normally type Chinese myself.

As I believe this is actually a bug, can you also add “bug” to the other forum categories to alert the developer? I can’t, but you may be able to as you started the thread. If you can’t I’ll send a PM about it.

:slight_smile:

Mark

I’m glad to see your reply. I also use Chinese MAC. Now I’m trying to work with this software and I like the working mode of this software very much, but I can’t feed back this error to the developers. If it’s convenient for you, you can feed back. Thank you.

报错 笔记

Hi again.
You can directly report the bug to Literature & Latte using this link :

The “bug” tag has been added to the thread.

1 Like

Thank you to whoever added the Bug tag … I couldn’t find how to do it.

Although I use Chinese, my system is UK English. That doesn’t prevent me from using Chinese, but I don’t know the terminology of the Chinese interface, only what I see in Screenshots. :smiley:

Mark

P.S. I have submitted a bug report, along with my small test project and the settings file to make it easier for the team to try it out.