Formatting Bugs?

I’m originally a Scrivener user from Mac, since v1 but through the third. Having recently gotten a new Windows laptop (and no longer having access to a Mac) I was elated to see what Scrivener 3 at last released for Windows. Naturally, I downloaded the trial before immediately committing as it just came out. I know things take time to get going – that said, outstanding work to the developer(s) after a long-awaited release!

Unfortunately I seem to have run into a few issues, and am wondering if I am alone on these, or if they are known issues. If so, is there a workaround until it can be fixed?

  • Previously on Scrivener 3 (Mac) under the Scrivenings mode I was able to do a mass-select and edit multiple pieces from multiple documents in the binder. I tried replicating this with control selecting or dragging, but it doesn’t seem to work quite the same. Is this functionality not possible on Windows?

  • The biggest of the three issues. Styles do not seem to entirely save properly. While they do appear right in the Styles Panel, every time I save and reload the font entirely changes to something completely different, as do the weights. I’ve tried redefining, brand new Scrivener Projects (even with no defaults styles set). Nothing seems to fix this.

  • Copy-pasting doesn’t seem to capture the formatting from browsers or other applications as it did on Mac. While it does capture the text, sometimes colouring is important for highlighting. For now it’s just as if I copied something from Notepad into Scrivener – no formatting at all.

If anyone has any insight or if these are known issues, that would be wonderful!

Thank you!

Welcome to the forum, and sorry that sign-ups were offline for a bit there—hopefully that wasn’t holding you back from posting.

To answer each in order:

  • That’s a known technical limitation in the Windows version. They just don’t have the right technology available to combine multiple texts into a single editor like we can on the Mac (even iOS cannot do this). So Scrivenings is more like a stack of individual editors. What are you are attempting to accomplish with this though? There may be another approach you can take.
  • The styles issue will need a more precise reproduction checklist for me to check into. I’ve never seen that happen myself, but you could be trying fonts or settings I’m not typically using.
  • That kind of interaction depends a lot on how the third-party program is handling the clipboard. This is not unique to Windows, it is also a problem on the Mac as well, with some browsers for instance. If you have some specific examples we could try and address them individually. In the meanwhile though, you may have luck passing the text through something that can read the initial program’s rich text clipboard, that Scrivener can also interface with. LibreOffice, for example, may work, or Word.

Hello Amber!

Thank you for the welcome. Unfortunately it did affect me for a bit, but no harm done!

A bit unfortunate for the technical limitation, but I understand.

I’ve oddly never once had the clipboard issue in all my years using Scrivener. Curious to see that it affects this, but I will try your workaround.

Usually what I do for this is selecting and copying a quote via Chrome or Firefox. Often these have some form of rich text, usually colour. The quote itself copies well enough (usually), but the formatting does not when transferring to Scrivener (Windows v3). It has worked plenty of times however on all the Mac versions.

As requested, here are the steps and information.

The primary font set I use is the Proxima Nova family, however I have also tested this with system-provided fonts (Agency FB, Calibri, Times New Roman). All seem to be affected curiously, and switch to something else.

My steps:
1.) Start a new document (or project & document).

2.) This project has no default styles – I remove them, to start fresh, save for the Main Editor formatting set under options (rather than the Styles Panel).

3.) I start with Heading I (as followed by II - IV, Subtitles, Sections, and Body). All I do for this is usually centre the text, modify the paragraph spacing before (5pt) and switch to the SmallCaps variant of the font. If the font did not have one, I toggle the transformation.

Initially this renders well. Not perfectly (as the Windows text engine can be glitchy at times), but well!

4.) Save the document after I’ve entered content.

5.) Reopen – everything except the Body style has changed. The fonts are something entirely different, as are their weights. The only formatting kept was the alignment and usually the size.

6.) This also affected the other mentioned fonts, I can try more but wanted to be able to reproduce with more than just the main font family I use.

I hope this helps!

I tried another test this evening, just to be safe.

First I removed all the styles from the document again, and tried a standard font change with no styles existing. Using a different system-provided font (not included in the ones above) it switched itself again upon reloading the save.

The same is true of a completely new project.

Clipboards: I used to get the clipboard issue on the Mac all the time! I think the main culprit was Firefox for a while, but that was many years ago. I will say the experience has been smoother in recent years. I am not surprised to find Windows a “rougher” experience, as it seems interoperability between software is, in general, a bit less of a thing (maybe even in a cultural sense). But I digress.

Usually what I do for this is selecting and copying a quote via Chrome or Firefox. Often these have some form of rich text, usually colour.

Interesting, I do get a fair amount of formatting from Vivaldi (which should be functionally very similar to Chrome). For example I copied my post from above, and got the italics, hyperlinks (from the username and post date) as well as functional bullets.

But an important caveat is that I’m trying this on Linux, with Scrivener running through WINE. You’d think if anything that would make things worse, but who knows?

Styles: I’m curious what happens if you try creating your styles without using the small cap font variant or faux caps transformation option. I couldn’t reproduce the issues myself, but I could see either of those as being potentially more problematic.

Since you mention “body” works fine, I suspect that might be the missing ingredient. It would help to know the precise settings you are using for these styles, since faux caps uses a font size hack basically.

As for Proxima Nova, it would expensive to test the font itself, but from I can see on its store page, it appears to not have a dedicated small caps font variant, but rather makes use of the typographic ODT settings for this? That would work fine on the Mac, where the text engine can access advanced typography, but that’s not really a thing in the Windows version. I’m not sure how you’re accessing it in the first place, but it may very well not stick.

Hello again Amber!

I use Vivaldi as well as my primary browser, I adore it! Most just have no clue what it is when I mention it, but it’s Chromium based so I often say Chrome. Compatibility wise they are almost identical.

As for your suggestion I’ll look into it.

Proxima Nova is indeed VERY expensive. It’s a designer font (I do commission work on the side, so it’s become an asset). The 126 Font Family package is no longer available to my knowledge, as Mark has bundled most of them into a simple set now as far as I know.

Previously you could get the SCOSF (Small Caps, Old-Style Figures) along with two font family versions of the primary font itself. This package is the one I have.

So some notes I’ve tested. The font family works fine in WordPad, Word, and LibreOffice thus far. When saved they render properly when re-opened. Scrivener is the only odd ball thus far, which is truly odd for me. In the past it was exceptionally rare for me to have issues with Scrivener.

Below are the settings I use:

Header Style
Proxima Nova SCOSF, Extrabold
35pt, 5pt Space Above, 0pt Below, 1.0 Multiple Line Spacing

Section Style
Proxima Nova SCOSF, Condensed, Bold
25pt, 5pt Space Above, 0pt Below, 1.0 Multiple Line Spacing

Sub-Title Style
Proxima Nova SCOSF, Extra-Condensed, Bold
15pt, 5pt Space Above, 0pt Below, 0.8 Multiple Line Spacing

Body Style
Proxima Nova, Regular
15pt, 0pt Space Above, 15pt Below, 1.0 Multiple Line Spacing

Colours default to RGB(50,50,50), or HEX #505050. No changes between styles to keep things simple for testing. Everything works perfectly fine for the Body Style, which also happens to be my Default Formatting for Scrivener – I’ve had it this way for years.

Vivaldi is fantastic! I was crushed when the original Opera was discontinued, as it was really the only browser aimed at people that wanted a feature set. Everyone else was going simpler and simpler, no settings, few commands, stripped to the bone bookmarks, etc. Vivaldi had some rough patches, but at this point it is solid as a rock and very powerful. It’s great if you want to completely separate work from play, too, with its profile feature.

So some notes I’ve tested. The font family works fine in WordPad, Word, and LibreOffice thus far. When saved they render properly when re-opened. Scrivener is the only odd ball thus far, which is truly odd for me. In the past it was exceptionally rare for me to have issues with Scrivener.

Thanks for the notes, that will help in testing. Are you using either of the font checkboxes in your styles?

Yeah, well all of that is going to be completely different than what Scrivener is doing internally. Since neither the Mac nor Windows text editing component is capable of working with native RTF styles directly, we have our own system that kind of sits on top of RTF. In fact if you were to open one of Scrivener’s internal RTF files in any other word processor you’d see what I mean (and you’ll see why we strongly recommend not editing its files that way!).

So it is certainly possible that there is a bug in that, somehow. I’ve never seen it myself, in the years of using the beta (save maybe for very shortly after it was implemented and before it was even public). So it is strange that you are seeing this with such regularity and ease. But I suspect it is something to do with the variant issue—there may be issues with oddball variants that aren’t simple italics/bold/italics+bold. If that does seem to be the case, I can hunt down a free font that does similar and give it a try. If that is the case, how does it work for you? Is there a whole separate major font family that is small caps, or does it come up in the variant toggle to the right of the family selector?

1 Like

Apologies for the delay.

I wanted to run another test.

Both checkboxes are checked. I noticed something from your suggestion of trying the SCOSF versus the Transformation.

The SCOSF is not kept, whereas the Transformation is (partly). There is a difference here though – when clicking on the Transformed text it squishes itself to the point that it becomes unreadable. A weird screen glitch indeed.

To answer your other question.

Proxima Nova (the version I have at least) works different depending on the platform.

On Mac, it’s treated all as one huge font family with multiple files. It groups them together as a single font, with MANY weights. (The second combo box box scroller)

Windows they are all separate files. One font for Standard (Non-Condensed) with Thin, Light, Regular, Medium, Semibold, Bold, Extrabold, and Black weights with their Italic equivalents. One for Condensed. And one for Extra Condensed. The same is true of the SCOSF family. So six font families in total, equalling about 126 font files. HUGE library.

I’ve done a bit more testing on this front, still with no luck.
I have however noticed something in common here, regardless of the settings.

No matter if I use different fonts by selection and no styles, or via creating a style the text will automatically revert to the default font on reload. Sometimes it will keep other formatting (size/colour), sometimes it will not.

The text glitch on Transformation for Small Caps also continues. I’m beginning to wonder if it might be a bug in the RTF engine itself, and not just pertaining to small caps.

Thoughts? Suggestions? At this point, if I can’t even format I’ve lost a great deal of functionality I once adored in Scrivener. Or any word processor for that matter.

We’re probably getting outside of my ability to help, except in general ways, given I’m not a huge expert on the Windows version. You might want to contact tech support directly to have someone look into this, as that sounds like a deeper problem to me than an edge case.

But in your shoes, the general puzzle solving technique I use to figure out the nature of most problems is the old building block approach:

  1. Go into File ▸ Options... and save out settings to a file with the Manage button.
  2. Click the Defaults button to factory reset the software.
  3. Reload Scrivener.
  4. Create a new project using the Blank starter.
  5. Type in, “This is a test”, at the blinking cursor.
  6. Hit Ctrl+A and bring up the font panel to change it to Consolas-Regular 12pt.
  7. Close and reload the project.

Now according to your description, you would expect to see the text load in with Sitka 14pt (or maybe 12pt, I forget), the default formatting used in a fresh install.

I suspect though, you won’t, because if that’s all it took, we would have tens of thousands of open tickets right now. :laughing:

So the next part of the procedure is to add complexity. Change the definition of what default formatting means in Options and repeat the test from step 4. Try putting the default formatting into Project Settings, if that is what you normally do, again from step 4. Work up to selecting your personal favourite font rather than the system Consolas… etc.

Work toward what you have (which you’ll know better than me), from a premise of no assumptions at all. Likely at some point you’ll find the one thing that makes it crumble.