Formatting Help for Paragraph Spacing

It’s been a few years since I last Compiled, and I don’t remember what I did last time.
My manuscript appears to have paragraph breaks after every line, so when I compile, there’s empty space between those paragraphs, which I don’t want.
Here’s how it looks in my manuscript:

Here’s the compiled version:

I emailed support a couple of times, but never heard back, so hoping someone here can help me.

I’ve checked all my compile settings around line spacing, but nothing I change in my formatting options seems to make a difference.

Any help is appreciated.

What you are seeing is a difference in paragraph Space-After setting (not Linespacing). Your Compile setting is also set to have no first-line indent. Presumably you want to change both these paragraph settings.

If you know how to adjust these two paragraph settings on a paragraph in the editor, the way you do it is the same in your compile settings, only you have to find the relevant Section Layout to adjust:

Do this by first observing what is the Section Type being assigned to your docs. (You can see this in the right panel of the Compile dialog.) Then observe what Section Layout that section type is being assigned to. This is visible in the center pane of the Compile dialogue. You want to edit that Section Layout. You can tap the little pencil icon showing on its representation in the center pane for quick access.

This will take you into the Section Layouts area of the compile format settings sheet with the particular section layout selected. Below that you will see a sample paragraph with formatting ruler bar. Adjust your paragraph setting just as you would for a paragraph in the Scriv editor area.

Thanks @gr I believe I’ve got that configured the same, but see no change in the compiled file.

What I’m seeing there is the “Chapter” format for Body. That should be the correct thing I’m looking for, I think.

I ended up opening my last manuscript and exporting its project specific template, then importing it to the global templates.

I still don’t see what I did differently, but at least it’s formatted how I want now.

It looks like you thought you should edit a Paragraph Style in your Compile settings. But “Body” is just the name of a style – which has no built in connection to your body paragraphs. Hence, nothing happened.

If you are following standard Scrivener practice, your body text does not have an assigned style. So, you were editing your Compile format in the wrong place.

Here are some pictures of the approach I described (which does not involve editing any paragraph styles).

The look you set for the template paragraph at the bottom of the last image determines how all unstyled body text looks (for docs whose section type is assigned to this particular section layout). That will effect every ordinary paragraph of such docs (i.e., all except those you have explicitly assigned a paragraph style to for some reason).


1- The above answer is the correct one. Avoid using styles all over your body text.

2- Even if you did use styles everywhere, it is obvious that your “body” style as indeed a space-after in your last screenshot.

It sounds like you were able to get the formatting you want by using your previous Compile settings. Just wanted to note that we do reply to all support queue emails, so if you don’t see a reply from us within a couple of days, it’s likely gone to SPAM or otherwise been filtered out by your email client. I replied to your original formatting help request on December 09, if you want to go back and have a look.

1 Like