Formatting preference changes don't stick

I’m trying to set the default formatting preferences, and I’m finding that the preferences dialog is busted. As I am changing presets (for example to set the style of blockquotes, then main body, etc.) preferences like font family, style, leading, indents, etc. are not saved.

Here is a YouTube video that illustrates the sort of problems I am having:

The same problems happen in the dialog at the Project > Text Preferences… level. And in the document editor the styles reset to some with a particular monospace font that I have used in the past with other documents, but I have no idea where Scrivener is dredging up this preference from.

Is there any way I can obliterate whatever crufty preferences I have accumulated to get this dialog working again? The current situation is very frustrating.

I think I have worked out what is going on, by RTFM: I have realized that formatting presets live outside a particular document, and you don’t edit them through the Formatting preferences but through Format, Formatting, etc.

The apparently flaky application of properties I was seeing was due to the predefined presets setting paragraph styles, or paragraph styles and font styles but not character attributes, etc. I guess that is what the little paragraph mark/“a”/underline glyph means on the preset selector.

I still don’t know where the monospace font came from occasionally, but it seems to be banished from new documents at least.

To change the formatting presets, you don’t need to go into the Preferences at all; that’s for setting the default formatting that will be used for all new documents (or if you use Documents > Convert > Formatting to Default Text Style) and the presets are available there for convenience in case you want to select one to use as the default formatting–it’s not a place you can update the presets themselves. To update the preset, simply format a paragraph of text in the editor the way you want it, then with your insertion point in that text go to Format > Formatting > Redefine Preset from Selection and choose the preset (e.g. “Body” or “Block Quote”) that you want to update. You could instead choose New Preset from Selection to create a new preset.

Keep in mind also that these are simply static formatting settings, meaning that you can’t apply the “Block Quote” preset to various paragraphs and then update the preset and have those changes propagated to all the previously-formatted Block Quote paragraphs. There’s no link between the formatting “style” and the paragraph; the presets are just saved formatting that you can quickly slap on any text in a single action rather than having to constantly adjust indentation, spacing, character formatting, etc. So if you change a preset, you’ll need to re-apply it to any text you want formatted in that new manner.

Preferences is the place to change the default for your new documents–in Scrivener >Preferences to change the global default for all new projects, or Project > Text Preferences to change the new document default just for the specific project you’re working in (this will then take precedence over the global default). So your new documents would use whatever formatting you applied here, and then you could further format text within the documents using your presets while working in the editor.

Whoops, a minute too late, but I’m glad you got it sorted. Re: monospace, I’m not quite clear what’s happening there–is the whole document using monospace or is it when you apply certain presets, etc? The default font in Text Preferences (i.e. what it is before you change anything) is courier, I believe, so if you had at some point enabled the override there, new documents would use that–if you then disabled it again while trying to sort out the formatting issue, new documents creatd after that point would revert to using the global font set in Scrivener > Preferences. You could select those documents and use Documents > Convert > Formatting to Default Text Style to bring them into sync with the current defaults for the project, but if you’ve reformatted sections of them you may want to pay particularly close attention to the options presented or try duplicating the document first and doing a test run converting a copy to make sure you like the changes.

Another random thought is that you may have set some documents to scriptwriting mode (but using the general setting, so it’s not being formatted in spacing, etc. like a script), as all the script settings use a monospace font. For script documents, the document icon will be yellow and you’ll see script elements in the editor footer (“General” I’m guessing here) rather than the word/character counts; you can deselect Format > Scriptwritting > Script Mode to switch it back to a regular document and then use the Formatting to Default Text Style to adjust it as above.