Formatting Problems

I’m having a few problems with the basic typing and formatting part of Scrivener. I want it to behave like a basic word processor, but I get it to. Suggestions?

1. Tab doesn’t tab.
When I hit the tab key, it won’t indent but instead gives me a new line altogether, like hitting the return key.

2. Lists don’t list.
When making a numbered list I run into this problem. I have a list numbered 1-5. Then I start a new line, turn off numbering, and type a new sentence. Then I start a new line and try to number again using the numbering formatting option. The result is that my recent un-numbered sentence becomes numbered, too. If I try to turn off numbering in that sentence, it turns off numbering for lines below it.

3. Return to default formatting?
Is there a way to return all settings to default? This would be great.

  1. You need to set tab stops. You can turn on the ruler and do this in the editor for individual documents, but your best way is to open Scrivener>Preferences and click on the Formatting pane, then set the sample text there to how you want your default formatting. Tab stops added to the ruler there will become the default for new documents created. (There should be some by default, but they may have gotten removed at some point or you may be tabbing more times than there are tabs.) If you have text in the main editor already formatted the way you’d like your defaults to be, you can select that first and then in the Preferences:Formatting pane click “Use Current”. That will copy the tab stops from your selected text as well.

  2. Apple lists leave something to be desired, agreed. The best way that I’ve found to do this is to make the numbered list, then escape the list by hitting Return twice–that will put you just one line down but out of list-mode. Type as usual, then when you start a new line for the next list it should recognize it as a new list and not reformat your previous paragraph to become part of one large list. Alternatively you could add some extra carriage returns before you make the first list, and then just jump down to them after you finish the list to return to the normal formatting; again, a new list created after that should be recognized as a new list and not a continuation of the earlier one (which then causes the Apple text system to graciously reformat your non-list paragraph, since obviously you made a mistake :unamused: ).

  3. If you mean changing your existing documents to default formatting, you can use Documents>Convert>Formatting to Default Text Style. This will change your selected documents to the styling you set in Preferences:Formatting. If you just want to reset factory settings for all global preferences, you can click the Defaults button in Preferences, but for a lot of things that won’t affect existing documents in your project or other project-specific settings (though you can then run the convert command above to change older documents to the default).

Thanks! That’s a huge help.