Formatting Randomosity

When I copy and paste from Word, I randomly lose italics and bold, get random text settings (sometimes Verdana), and when returning to a text document, it has always lost the first line indent on paragraphs (and since there isn’t an option for double-spacing, that makes really hard reading), and frequently the align justify. Randomly tries to change to some MS font as well. ???

Me too. I’m using Windows Vista on a Dell Inspiron 6400 notebook and when I copy and paste from Word sometimes everything is fine and other times inexplicably all the formatting is lost, including line breaks, paragraph breaks etc.

I’m on Windows XP on a Dell Inspiron desktop 530

Aargh! I don’t mean to sound dramatic but I’ve just now closed Scrivener and re opened it. All the formatting I had corrected and saved before closing is now lost…
I have also tried saving the text as an .rtf file before pasting it into Scrivener and immediately saving the file. As before, the formatting looks great until I switch to looking at another chapter or close Scrivener, whereupon all formatting is lost.
PS I am using Microsoft Word 2003, an ancient version I know but it works for me. (Or has done up till now.)

First, before doing anything: Are you running the most current version of Scrivener. To check hit Help -> About Scrivener to verify you are on version 1.3.

Unfortunately, there are NOTORIOUS import and copy bugs with the RTF system that have yet to be fixed. Personally, I copy all of my text into notepad (eliminating ALL formatting) and then copy it into Scrivener. We hope that some of the import issues will be fixed with the next version (1.4) but there is no guarantee.

In my experience formatting inserted once the text is in Scrivener should stay. I will be glad to help anyone if you are still struggling to get it to work. If you are worried about your first line indentations here’s a tip:

-Open the blank page in Scrivener you want to copy your text into.
-On the Ruler at the top, pull the top gray arrow over to create the first line indentation.
-Instead of JUST PASTING use Edit -> Paste and Match Style.

This should place a first line indentation on each paragraph you pasted in. With out you having to do it all line by line. Also, if you select the font face and size you want before Paste and Match Style it will copy it in the font you selected.


You can copy the text in, hit CTRL-A to highlight it all, and then drag the little gray arrow over to creat the top line indentations. Also, with some experimenting, I discovered that BOLDS and ITALICS copy better from OpenOffice then from Word.

Hope some of this helps.

I’m running beta 1.3 and it does not retain anything other than bold, italics, and font size and type once corrected. Indentation gone if you simply switch view and return. Alignment out the door for flush left. I cannot get it to retain these settings at all. Even after I changed the “default”—it still does not retain these. And I’m copying and pasting from Word. I use italics to a fault. It would be a nightmare if I killed all formatting (have tried this in the past with a different internet-based text editor.’s editor works well for stripping all other formatting than bold, italics, etc., but I have not tried that yet with Scrivener because I actually want it to KEEP my formatting.

As for import, I pretty much never use import because I’ve never had ANY program’s import function work correctly and because I find Scrivener difficult to write in if it won’t keep indents and has no double spacing. I like writing in a text editor that stays out of my way. (Word does.) I’m using Scrivener to analyze my writing for a revision.

Alright, I’m a little scarpered. Scrivener keeps my formatting. I can leave the page, or even the whole program, reopen and my first line indents stay, as does all my other formatting. As you didn’t import the file, but created it in scrivener and copied it over, I’m really really really not sure why it is doing that.

I supposed you have tried creating a new text file and trying the copy in again? Which program were you copying in from?

Word. And yes, this happened with ALL my new text files.

Yeah, we’re going to have to wait on a developers input. I used to have that problem on Beta 1.0 but not on 1.3. Since 1.3 it’s kept all indents. I’m sorry I can’t help. I’m tempted to tell you to uninstall and then reinstall but I hesitate as I’m not sure it’s your install. It’s just very unusual to see the Beta GENUINELY behave COMPLETELY different on two different computers.

Well, I went and redownloaded anyway. It DOES look different. I’ll come back and post later if the problem persists.

Maybe that’s it! Let me know, I’m really curious to see if it fixes things.

Looks good. Odd that, but I won’t complain. :smiley:

Awesome. So if anyone else is having format sticking problems, I now definitely suggest reinstalling. Your project file will be untouched by uninstalling or reinstalling, but backing it up wouldn’t hurt.

Mightygitis your post about running text through Notepad was great and works really well. Thanks! Thanks for those other tips as well, re bringing text in with the right font etc. they’ve suddenly made life a lot easier.
I have Scrivener 1.3. If it does anything really odd I’ll re-install as suggested but so far so good. :smiley:

I can’t set the paragraph spacing. I have to copy a paragraph from word with say a 6pt spacing to get it to work. But as I’ve come to expect with word I sometimes get more than I wanted and it brings over margins. They only appear when I go to Full screen mode. If I esc out and then get back in it behaves normally. It seems to only happen on the first time I enter full screen mode in a session.

Loving scrivener - will be buying the product for sure!

I’m also having formatting problems. I’m copying text from within Scrivener and from Firefox. When I reopen the project, some documents have lost all their returns, therefore, it doesn’t matter how many paragrpahs I had, they all become a single paragraph. A few numbers are lost as well. I’m copying from the Chicago Manual of Style (some notes for comparision), and the first time I paste, some times it turns all the text blue, as if it were a big hyperlink. If I copy and paste from Scrivener into Scrivener, almost all the blue text disappears, but a few characters remain blue and underlined. When I reopen the project, these blue numbers or characters disappear. It’s kind of random, since a few documents remain untouched while others, created in the same way, just loose all the paragraph divisions.

I’m waiting for the new version, but I’ll try reinstalling and see if it gets any better. I’m alsy trying the NotePad thing, in order to find out if it makes it better, but some of the text that has been affected wasn’t pasted from an outer software, but generated and pasted from Scrivener.

I hope this information helps.

Update: reinstalling didn’t help. Reformatting did, it’s just that it increases my amount of work :cry: .

You said it lost formatting every time you reopened, so now is it holding the formatting now that you reinstalled? The reinstall wasn’t meant to fix the formatting but to fix the fact that the formatting kept disappearing. So you would only have to reformat everything once and then it would stay.

Obviously the documents that lost their formatting would have to be reformatted again. They’re lost (as well as many hours of work, I’m afraid). What I did after reinstalling was trying to reproduce the problem, step by step, with new documents. That is: I created a new document, I copied and pasted my basic information from Scrivener (basic template info), I copied and pasted a paragraph from Firefox to Scrivener, I quit Scrivener, I reopened Scrivener.

After I reinstalled Scrivener, this is what happened:

  1. If I just copied straight from the browser window to Scrivener, quit Scrivener, reopened Scrivener, all format was gone. That includes the paragraph marks from text not copied from the browser but from Scrivener.

  2. If I copied from the browser to NotePad, and from NotePad to Scrivener, quit Scrivener, reopened Scrivener, the format was kept. That also includes the paragraph marks from text not copied from the browser but from Scrivener.

Why does that happen? I have no idea. Those are the mysterious ways of RTF formatting… :frowning:

We can hope that the next Beta which is supposed to fix the RTF issues will fix this.