Forum Fails [to upload images now and then]

Don’t ask me why.

List item

I won’t ask.

I will say that when I see these error messages (very infrequent, but self-inflicted when it happens), it pretty much means what the error messages say.

Issue is on your computer and not fault of forum. Find the “another window” and handle. or to be really safe, copy to clipboard everything you wrote, shutdown browser, restart, and then start a new post (paste content from clipboard).

Needless to say, I didn’t have an additional tab open for editing. What I suspect is that the forum is not very forgiving when trying to load images from far, far away. Compressing a png to a jpeg (324k to 160k) helped. Javascript error reporting could be better.

I posted because sometimes errors like these are symptoms of other problems and so their web team can keep track.

I get that sometimes.
It generally coincide with a noticeable drop in the quality of my internet connection.

The problem, I presume, is then my Ping. Not the forum itself.

1 Like

The best place to search for and post bug reports about the forum software itself is on the Discourse forum.

In order to communcate with Discourse, I have to set up an account with them. I have no relationship with that company, nor do I particularly want one.

The problem happened again today: upload failed, followed by an error message claiming that the post is being editd in another window–it’s not–.

In general a statement of “it doesn’t work” needs some additional information for the wizarding nerds to help you. For example, are you on a phone or a computer? Which operating system? What browser? Right now all we can know is that you seem to have some unique setup that the rest of us do not.


I’m not sure why you’d presume that I’m one of those wizards who dumps a raw packet feed into a VM sitting on top of BSD, processes it through a beta version of npm and then converts it through a hacked version of Opera 12.15.

Let’s presume Mac, 32-bit (no alternatives for Picasa or Taply) plain vanilla Firefox 106.0.5, logging on to the forum without a proxy.

With no error reportng beyond what I have reported, there’s not a lot I can do.

Jaysen wasn’t presuming anything.
All he/she said is if you have an issue, describe it whole, along with its context. Else, you are not giving anyone who’d want to look into it much to look at…

A bit like saying you have an issue with a Scrivener project, that it suddenly changed on you, when in fact it is rather a document that you only just now imported from an other app, but you don’t mention it… (Just sayin’.)

Now in case you missed it:

When you get the first message (“Sorry, there was an error […]”), close the forum and relaunch it.
That usually spares me the upcoming issue.

1 Like

I’ve seen both those errors, both on my Mac, and on my iOS devices.

  1. It might be Firefox related, as I use Firefox exclusively on all my devices.
  2. The file upload fail may be due to an inappropriate response to a network glitch (communication failure) as a second attempt to upload has always worked (so far).
  3. The “another window” message has always appeared after I’ve switched to another tab in my browser and then switched back, or stopped editing to look at something else in the forum. I’ve learned to save a draft if I need to go look at a different browser tab or stop editing for any reason.

It frankly never occurred to me that any of this was under L&L’s direct control. If I couldn’t work around it, I’d have gone to Discourse and complained. But I can work around, so I haven’t bothered.

1 Like

Google chrome for me.

I’m on Windows + Chrome. I sometimes see that message when I’m editing a post and open another tab to any other page of the forum. Workaround is to close the other tab.


Perhaps I should add that in my case I run the forum as a standalone.
One day Chrome offered me to “install” it like it’d be an app, I did and liked it.
Else, I wouldn’t know how to tell someone how to do it, as I can’t find anything relating to this when opening the forum in my Chrome browser. (It is not an extension. And of course I no longer get the offer to install it as a standalone.)

So in short, when I need two occurrences of the forum, the primary one is the standalone, the other is in Chrome. (Though both are technically ran by Chrome’s engine.)

Well, I didn’t presume that you were one of “those guys”. To the contrary, I presumed you were not one of those guys based on the lack of assistive information. At least I sure has hell hope you aren’t one of those guys as those of us who do fit that description should know better than to report an error without sufficient information to assist with diagnostics.

I will now crawl back under my rock, attempt to blow this ungodly assembly onto the 328p which needs another 4 forken bytes of eeprom (4. G. D. BYTES ONLY FOUR!!!) for this crap to work.

To fix your problem. Close all tabs and only use a single tab when on the site. For some reason, FF isn’t keeping cookie/tab associations correct. That confuses poor old discourse and it does what any marginally secure site should do… it distrusts your session and refuses to accept your upload. I haven’t traced if the uploads appear as a separate tab, but when I noticed the FF session mismatch on my RPI-based browser I figured I’d let you know.

Good luck.


If you are building a time travel machine, you know you can just sit on your A and do nothing, right ?
All you have to do is write on a piece of paper that you are on strike, and threaten your future self to never finish assembling the machine if he doesn’t send you the completed program to run it.

Easy peasy.

(Of course, at some point you are gonna have to take the threat seriously and finish the job, but for the time being it should technically be postponable.)

In all other cases : murderous robots are not as dangerous when left without legs. :wink:


I would prefer a time travel machine at this point. This is modifying a custom GRBL for a purpose-built CNC to make it more standards compliant and therefore able to be controlled with a wider array of control stations. I am happy to report that I removed the 4 bytes and now have the ability to terrible at deign for CNC in many different software products.

Yeah for me. :expressionless:

1 Like

Sounds great.
(I didn’t understand a single word of what you just said.)

I’m not sure I did either.