French punctuation : non-breaking spaces


(I use the 13th beta version)

I write in french and I have some difficulties with the punctuation.

I have found a way to change the english quotation marks into the french ones (yay me ! but, if I may, I would suggest you to make the change by default if the language chosen is french), but I have difficulties with the non-breaking spaces. Meaning, I have not found an easy way (if any way) to insert them (in Microsoft Word they are automatic). And we use them quite frequently in french ! It means I will have to correct those typographic mistakes by hand (probably in Microsoft Word) at the end of my last draft. Not an exciting task for future me.


PS : in the actual version of the windows’ beta, items in menu are both in french and in english. It is a bit strange.

I sometimes write in French. When I select French in RC13, the menu items are mostly only shown in French. In some of the drop down menus, there is the occasional item in English.

For the non-breaking space, try Inserer > Saut > espace insecable. That works for me BUT just a little warning, the menu item shows a keyboard shortcut of Alt+Espace. This does not work - it just opens the drop down behind the little Scrivener symbol in the top left of the window.

For the correct French quotation marks, «abc», the setting is in Fichier > Options> Corrections >Ponctuations > utiliser les guillemets automatiques and click the first drop down box to find «abc».


Thank you for your answer :slight_smile:

Comme dans Word, j’utilise Ctrl+Espace pour insérer un espace insécable. Si ce n’est pas le réglage par défaut (j’ai modifié pas mal de raccourcis au fil du temps), cela peut être modifié dans les options :slight_smile: