Full-screen crashing

Hey all/
I’ve been trying Scrivner for the past couple days and have totally enjoyed working with it except the nasty crash I get when ever I try to leave full-screen mode. Working in full screen is without problems, but using the button at the bottom of the screen to leave, always results in a crash. I just tried it again with a fresh reboot (no Quicksilver, one screen hooked up…) with the same result. BTW, I’m still using Tiger.
I would appreciate any help as this seems to be the only kink in an otherwise awesome workflow.

Rig: Model: MacBookPro2,1, BootROM MBP21.00A5.B07, 2 processors, Intel Core 2 Duo, 2.33 GHz, 2 GB
Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 256 MB

Report: Date/Time: 2008-01-06 18:49:36.560 +0100
OS Version: 10.4.11 (Build 8S2167)
Report Version: 4

Command: Scrivener
Path: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Parent: WindowServer [939]

Version: ??? (1.11)

PID: 1027
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0 libobjc.A.dylib 0x90a594c7 objc_msgSend + 23
1 …iteratureandlatte.scrivener 0x000a7dbf -[SCRFullScreenWindowController closeWithFade] + 157
2 com.apple.AppKit 0x93363dbc -[NSApplication sendAction:to:from:] + 107
3 com.apple.AppKit 0x93363d15 -[NSControl sendAction:to:] + 101
4 com.apple.AppKit 0x93365ec1 -[NSCell _sendActionFrom:] + 168
5 com.apple.AppKit 0x933786a1 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 1271
6 com.apple.AppKit 0x93396289 -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 848
7 com.apple.AppKit 0x93395b39 -[NSControl mouseDown:] + 757
8 com.apple.AppKit 0x933533e3 -[NSWindow sendEvent:] + 5279
9 com.apple.AppKit 0x93345384 -[NSApplication sendEvent:] + 5023
10 CocoaSuite 0x0068e1d1 -[NSApplication(CocoaSuite) cocoaSuiteSendEvent:] + 1089
11 …iteratureandlatte.scrivener 0x00021b6e -[SCRApplication sendEvent:] + 723
12 com.apple.AppKit 0x9326fe1e -[NSApplication run] + 547
13 com.apple.AppKit 0x93263d4f NSApplicationMain + 573
14 …iteratureandlatte.scrivener 0x00002e24 _start + 210
15 …iteratureandlatte.scrivener 0x00002d51 start + 41

Strange - I can’t reproduce this on Leopard and have never experienced this before. Someone once reported something similar but they could never reproduce it themselves; it was just a one off. Strange that it is happening all the time for you.

What are your exact full screen settings (that is, the way full screen is set up in Preferences and via the control bar)?

Tiger 10.4.11 seems to have introduced more problems that it has fixed in many ways - there are a couple of other crashes that people have experienced that seem only to happen on 10.4.11 (that is, they never happened on 10.4.10 or earlier and don’t happen on Leopard).

Does it also crash when you hit the Escape button to exit full screen mode?

Have you tried unchecking “Fade between modes” in the full screen pane of the Preferences panel? Does it still crash then or not?

Has anybody else encountered this?

Thanks - sorry you are encountering problems.
All the best,

I thought that it was strange, after searching the forum, that I couldn’t find anyone else having this pb.

However, when trying ‘Esc’ and ‘Opt-Cmd-F’ instead of the control bar icons to exit, I discovered that if I do not edit the document, I can successfully exit full screen mode. But as long as I edit the doc, it will crash on exit (though my edits are saved).

My settings are default except that I turned the ‘fade’ off…

yes, see above.

That’s the first thing that I tried when I started poking around…

This is really odd. I’m going to wait to see if other users reply to this. I’ve also added it to my “to do” list for 1.12, so I will definitely investigate behaviour on 10.4.11, although I’m not hopeful given that so many other users are using 10.4.11 but haven’t reported anything.

I’ll keep you updated if I find anything, and I’ll look at the relevant code again regardless.


I’ll be putting Leopard on this rig sooner or later and maybe that will take care of this pb. Thnx for your concern.

Hi Keith,
I am still running Tiger. I am not sure what version as I am at work at the moment, but I will check for you this evening.

I have never experienced a problem entering or exiting full screen mode.

kliger - just another few questions that may possibly be relevant:
Do you hide the main window when you enter full screen mode (it is one of the preferences, so I am guessing it is probably on by default, but it might be worth checking)?
Are you using an external monitor?



Yes, I usually work with both the screen on my MBP and an external monitor, but I’ve carefully gone through the exercise of going into full-screen mode with the external monitor detached from the MBP.

Thanks for your help, Matt.


If you have an older MBP make sure the system recognizes that the monitor is not there. On occasion, when I detach my external, the OS does not realize that it is gone. If I open the display pref pane and “detect displays” everything is good. I actually have the display icon in the menu bar just to make this easier.

BTW I was running 10.4.10 when this happened the most. I have been on 10.4.11 but not running the external enough to recall if it has happened since then. Apple indicated it was related to the display card in my version MBP. Not sure I buy that.

Thanks for the tip. I also keep the Monitor display icon on the menu bar since I do a lot presentations with projectors. I tried to see if a persistence display was causing the problem, but alas -no. I’ll keep trying.

Hi Keith,

I got the same problem right now. But on Leopard. Everytime I try to leave the full screen mode there is a crash. I am working with scrivener for almost half a year and never got a crash or anything before.
But now I can not leave full screen mode without one…
Very strange… Hope you can fix this? Are there more people with the same problem?


I wonder if this is specific to the project. Try creating a new project and entering full screen in that. Does that crash too?

If so, try deleting the preferences file - close Scrivener and then go to ~/Library/Preferences and delete com.literatureandlatte.scrivener.plist (you will need to reenter your licence details afterwards). Then reopen Scrivener and try again.

If it still crashes, post the crash report.

Also, try changing the full screen preferences - not to fade, not to have the other window open or vice versa - to see if any make a difference.

If it is specific to the project - if the clean project doesn’t crash - zip up the project and send it to me at support AT literatureandlatte DOT com so that I can test it.

Thanks and all the best,