Full Screen Fade Out

I don’t know if this is a bug or a setting I accidentally switched on, but sometimes when I’m writing in full screen mode, the screen fades to black (my background colour) and I can’t see the text anymore. Can I fix this?

Sounds like a bug. Hasn’t happened with me, though. I don’t know if this made a difference or not but I changed the color of my Full Screen background to an ivory shade. It’s less stark than white. Again, I don’t know if has anything to do with my screen not fading but it might be worth a try.

This does sound like a bug. Could you provide steps so I can reproduce it? I know you said it only happens sometimes, but if you can figure out when it happens vs. when it doesn’t, that would be quite helpful to tracking it down. Screenshots or a short screencast showing this would also be great–the more details the better, basically. What version of Windows are you running?

It’s possible to adjust the fade of the background by moving the slider in the right of the menu that pops up if you move your cursor to the bottom of the screen, but that only deals with the opacity of the background, not the page color, and so it shouldn’t have any affect on your ability to see the text.

I’m using Scrivener on several different computers. The one that it happens on the most is running Vista, but it has happened on XP as well, though not recently. I haven’t used it on Windows 7 or any other version. I have my page set to black and my background as completely opaque. My text is a bright green (retro ftw).

It fades as soon as I hit F11 for fullscreen. If I move the mouse or type, nothing happens (although what I type does actually go into the document, which I can see when I hit Esc).

I’d give you a screenshot, but it would just look black, which I don’t think is very useful. This only started happening recently on Vista. If I change the page and background colour settings, the problem goes away. It doesn’t seem to matter what colour the text is.

Hope this helps!

It does help, thank you. One thing to check, is your text colored black? Colored text will, at present, trump the temporary coloring that Full Screen uses, so if your text is not just “uncolored” but actually coded as black, when you go into full screen it will remain black instead of being green. This is frequently a problem with documents brought over from Mac, because unlike Windows the Mac defaults to specifically coloring text black rather than just leaving it uncolored but of course it’s possible that you colored it yourself by accident or that another program you copied or imported from had the text defined as black. If this is the problem, your insertion point in the text when in full screen should still be colored green, and if you have links they should still show up as your Full Screen link color. And of course this would always happen for any given document with black text, not just on and off, but it’s possible that it seems sporadic because you’re loading different documents each time and only some of them have black text. So that could be the cause, and it’s worth checking.

If that’s not solving it for you, could you let me know if you do see any other colors in your blacked out screen–for instance, could you turn on check spelling while typing and then type some gibberish and see if the red underlines show up? (Be sure to do this in just a single document, as check spelling while typing isn’t working properly in Scrivenings mode.) Likewise, is your insertion point in the text invisible as well? If you select text while in FS mode, does it show up in the selection highlight, or do you not get the selection highlight at all?

Sorry to drown you in questions, but it’s a puzzler and any detail could help pinpoint the problem. Thanks for taking the time to help us track this down!

How do I change my text to uncoloured? It is currently set to black under Edit>Options for the Editor, but I don’t see anywhere to change it to no colour.

It’s the same document, actually two documents that I open over and over.

I can’t see any red underline, highlights, or anything else - even the scrolling bar and the toolbar at the bottom disappear and won’t reappear.

I just opened it up on a different computer (also Vista) and it’s not disappearing, but the screen definitely goes a darker colour in full screen. I can still see the text though. This is really weird…

Has anyone else encountered this problem?

You can remove color by selecting the text and using Format>Font>Colors>Remove Color (also available by clicking the arrow for the drop-down menu in the font color button on the format bar). It doesn’t sound like that’s the problem, though, if you have no colors whatsoever and unresponsiveness from other parts of the interface.

Try creating a new project with a couple gibberish documents and testing those in full screen. It might be something that’s isolated to this single project, which would explain why you’re getting it on multiple computers.

You could also try resetting the preferences to the defaults, although these would be per machine so it’s perhaps not a terribly likely fix. You can save your current settings first by choosing Save from “Manage…” drop-down menu under Edit>Options. If you have an extensive personal word list, you’ll definitely want to save first, as that will get cleared when you reset to defaults (that will be fixed in the next update), but it’ll be saved with the preferences so you can reload it after testing this. Just reset to the defaults and see if your text appears correctly in Full Screen or if you’re still getting some oddities. If it works, you could then try resetting the retro coloring you had for FS and see if it continues to work.

I haven’t heard of anything like this nor seen it myself, so I’m just taking shots in the dark. :confused: