Full Screen mode color bugs: insertion cursor, text

I’ve encountered anomalous behavior in full screen mode. I’ve seen the text color problem described before, but not the cursor problem. For completeness, this describes both.

Running Windows 7, Scrivener Beta 0.0.26
Within a project, edit text as usual. Change some text to a color other than the default black.
With default colors (using Tools > Options > Defaults to make sure), switch to full screen mode.
Observe black insertion point using default background color.

Return to normal mode, use Tools > Options menu to change full screen text color to green and page (i.e. editing area background) to black.
Switch to full screen mode again.

Screenshot.jpg

Notice the following:

  1. The insertion point (the “I” beam cursor) disappears because it is still black. (It should be white or white outlined in black). This renders the fullscreen mode essentially unusable. Note that setting the type, size, or color of the cursor has no effect on the insertion point.

  2. The portion of the text after the colored text vanishes, because it too stays the default color; the text color override is ignored from that point on. In some cases, all of the text disappears (the text for the screenshot is Lorem Ipsum; most of the words can be located by the spell checker underlines) In the screenshot, all but the the red text has vanished, and none of it appears in green.

Please note–and I hope this is a clue–I do NOT see this behavior in the Beta 0.0.25 release running under Linux natively, or in the Beta 0.0.26 running on Linux with Wine 1.3. Linux distro is 10.04 in case that matters.

Thanks for your time,
Nathan

I am experimenting with colors, starting with full screen mode because I was going through the tutorial again (last went through it last November) and it first mentioned text colors in the context of full screen mode. I haven’t yet tried modifying any other colors.

I tried setting the paper color to black and the text color to amber, and chose several other alterations (links, highlights, etc.) to go with it. The highlight colors seem to be working.

I would really love to be able to use this feature as I am extremely light sensitive and it will really help. Please let me know how I can help find the bug.

EDITED TO ADD: I tried changing the text and background in the regular Editor, and found the same bug.

Using Windows XP Tablet.

laura1814 - Are you getting both issues mentioned in the initial post or just a problem with black text not showing up? The text can be fixed by selecting it and using Format>Font>Color>Remove Color (also available from the format bar or the editor context menu–which last you can use while in full screen). Some text that gets imported in will be specifically colored black, rather than having “no color”, so it will remain black and not get overridden in full screen. You might be seeing that in the tutorial as it was originally done on a Mac and Macs tend to apply black coloring to text. I’m working on fixing that in the templates, but as I haven’t updated them all yet you may find the same problem in some of those.

The cursor issue I haven’t been able to replicate myself yet. I get the white I-beam when on a black page in full screen and the insertion point in the text uses the default color assigned to text in full screen, regardless of the color of the actual text on the page. Likewise for reassigning colors in the editor. But you’re getting both a black insertion point in the text and a black I-beam cursor in both cases? And you get this on all documents?–for instance, if you create a new document in the binder and type a bit in it, you still have an invisible cursor and insertion point in both the editor and full screen?

If that’s the case, could you open Tools>Options and click “Save Preferences” from the Manage box in the lower left. Give it a name and save the file, and then if you could attach that in an email to support AT literatureandlatte DOT com, I’ll take a look at it and see if it’s something with the preference file that’s affecting this. It’s a long shot, but it’s worth a try.

Jennifer,

THANK YOU! “Removing text color” fixed the problem. Yes, it appears that it was just on the Mac-originated tutorial project. That was very puzzling to me, but your explanation (which would never have occurred to me) makes sense. It would be very helpful if this could be added to the tutorial, because I never would have figured it out on my own and would have continued to be very frustrated! :blush:

The problem now of course is that there is no way (that I have yet found) to select ALL text in the Draft. It has to be done file by file. Will this be changed at some point? I think it is a serious functionality flaw that you can’t perform an operation on all text within the Draft.

I do not have a problem with the blinking cursor. It appears in the text color in both the tutorial and in my created-from-scratch (not from template) project. Note though that I don’t see an I-beam, just a pipe. I’ll double-check that on my other computer before I copy the new colors over.

Thanks again!

Thanks, I’ll go through the Windows tutorial and make sure to clear out the text colours. This isn’t a problem with the default settings, which the Tutorial presumes, but it would be a good idea to do anyway, until this conflict is fixed. It’s not just a problem with Mac-originating files, it is also a problem with Word, which sets text to black by default.

That is something that will probably be fixed after the launch. It’s a pretty big project and will likely require recoding a lot of stuff to fix. The solution we have now is the best that could be done for now, but ultimately the ability to select all text in a Scrivenings session and perform formatting functions on it will be possible. It’s complicated since these are all technically separate files.

I am still going through the tutorial and I noticed something else I think should be changed. When talking about items in the binder, it says things like: “clicking on the triangle next to it” – but in Windows (at least with my settings), they are not triangles but plus signs.

Part 2. Organization
Step 9. Corkboard
View Options

“Go to View > Corkboard > Show Pins” should read
“Go to View > Corkboard Options > Show Pins” instead.

In fact there is a “View > Corkboard” near the top of the menu so this is confusing.

Also,

“You can also select Show Stamps via View > Corkboard” should read
“You can also select Show Stamps via View > Corkboard Options” instead.

“There are other viewing options available in the View > Corkboard menu” should read
“There are other viewing options available in the View > Corkboard Options menu” instead.

Yeah, that’s true. If you are using a classic Windows theme (which honestly I still prefer even after all of these years) you get [+] and [-] indicators. Any maybe XP? I forget if triangles were introduced in XP or Vista. It’s probably worth mentioning that in the preamble.

On the corkboard menu change; thanks! That one slipped by. There was another mistaken menu name a few paragraphs below that I fixed.

Glad to help. I’ve added a couple more as I’m going through it, but you’re just too quick! :slight_smile:

Re: plus signs vs. arrows/triangles/chevrons, I too prefer the “classic” view and use it in Windows 7. But right now I’m actually on an XP Tablet computer. It’s on its last legs but I love it dearly!

Part 2. Organization
Step 10. Outliner

“the binder does not show synopses (well, actually, it does show them in tool tips if you hover the mouse over items there, but the binder is more intended as a table of contents)”

I’m not seeing any tool tips/popups when hovering over items in the binder.

Are you still on your tablet PC? This should be working. I just tried it on Step 9 and the synopsis for that one came up after about a second of hovering.

(I should mention that I am also using the NaNo version, which is new than b35).

Still on the tablet, using b35, not NaNo version. Will update it shortly, I forgot to check for a new version when I sat down to work.

Next imperfection:

Still in Step 10 of Part 2, Outliner.
“The “Characters” and “Date”, so you can add those for viewing and editing in the outliner if you wish.”

Fragment alert! Fragment, I say! Seriously, I’m not sure what this is supposed to be telling me.

Sorry, where is the NaNo version? “Check for updates” says that Scrivener is up to date and literatureandlatte.com/scrivenerforwindows/ shows Beta 0.3.5 as the latest version.

literatureandlatte.com/nanowrimo.php

I just deleted that sentence as I have no idea what it was referring to either. :slight_smile:

Back to the original subject, the colors.

In two places (so far):

Part 1, Step 3, Footer View
Part 2, Step 11, Scrivenings

the background of part of the text appears to be set to white, and I don’t know how to fix it. (The text is appearing properly in my color.)

I have been selecting the text in each section as I come to it and “removing color” from the font, so that my new colors (black background and amber text) will apply.

The similarity between the white-backgrounded sections above (which is overriding my color choices) is that they follow a highlighted line of text. So it is probably a hidden code saying something like “return to original background,” only it specifies that it is white.

Thanks for the prompt response about the NaNo version! I’m off to get it. :slight_smile:

Back to the tooltips, I think I was just being stupid. Not all of the items have summaries. The ones that do have popups/tooltips after a second or so. Sorry for the confusion.

I’ve downloaded the NaNo version. Still working my way through the tutorial, about to get to some of the new stuff. Thank you!

Part 2, Step 13, Collections

"Click on the “Collections” button on the left-hand side of the toolbar.
“You will see an extra area appear at the top of the binder with a blue and purple tab in it. . .”

Only problem is, at the end of Step 12, we did a search. Closing the search did not change the view in the left hand pane. So clicking on “Collections” actually turned it off, so that I no longer see the extra area at the top of the binder with a blue and purple tab in it.

Part 2, Step 13, Collections

“To see what I mean click on one of the documents in the collection list. . .”

This should be “right-click.”

“Once you were happy with the arrangement, you could select all the documents, Ctrl-click on them, and use Move To from the contextual menu to move them all to the location in the binder you want them.”

This should also be “right-click” (not “Ctrl-click”).

Part 2, Step 13, Collections

There are a few references here (and in Step 12 I think) to the search results background being purple. It looks gray to me, not purple.

I did make a change to the binder background color, but don’t know if the change I made could be affecting this, or if the gray I am seeing is in fact very pale lavender, or what.

That’s all for tonight. I will try to finish the tutorial tomorrow or the next day. Thanks for your help tonight!

Okay, I’ve added white highlight removal to the to do list for the next revision. You can remove highlights, by the way, like fixing text colours. Just select the text, right click, and use the Highlight menu to “Remove Color”.

That really should be fixed for the launch as it represents a usability issue. New users find it confusing enough when their binder doesn’t show everything for the then-mysterious reason of it being replaced by search results. It is more confusing when the background looks the same. A clear colour difference makes it obvious you are not looking at the Binder; and that is helpful to veteran users too. So I’m leaving that reference in; as well as the screenshots that depict it as such.

And yes it is possible to change the colours for both the Binder and Search Results in the Appearance tab. “Recent Search Background” and “Binder Background” are the two keys.

Right-click fixes: done.

Okay, I think I’ll leave that as-is though because the instructions should also be pointing to the X button in the footer bar of the sidebar which returns you to the binder and that along with the first tip to clear the search should be enough.

That should have worked though, clicking the X in the search field; maybe that is a beta version difference.

Thanks again for all of your help!