full screen mode – keep text centered no matter of the paper sheet width?

Hi everybody,

I have a small problem: I’d like to keep my text centered in full screen mode even if I increase the width of the paper sheet (as I am working on a big 27" monitor, the text already moves to the left even when it only is a little bit wider than a small stripe with lots of background). See my attached two screenshots, I hope they are self-explanatory (sorry for the wrong order). Although I admit that the text going left would be “logical” behaviour if you really consider the white part of the fullscreen as a virtual paper sheet, I hope and I am sure there’s a setting somewhere I am missing to change this. Otherwise, you really only can have a too small white stripe (IMO) on big monitors. (The small width on my first picture already is the maximum – from then on, the text starts moving to the left.) Thanks a lot in advance for the help!


Hi

That is, I think, to do with the right-hand ruler settings restricting the width of the text. In the sample file attached, the first paragraph is set to the margins used for a typical A4 page. The second paragraph is set to about half of that. Opened in composition mode, the first paragraph can expand far more than the second one.

To change the margin, (1) press CMD R to show the ruler, (2) put the cursor in the paragraph you want to change, and (3) then reposition the right margin marker as you want.

Slàinte mhòr.

Test.zip (43.3 KB)

Thanks a lot for your reply, really appreciated – I’ll try this out. Just had a quick test, but it didn’t work yet. Maybe I haven’t changed the correct arrow yet, but I’ll try everything with a test file so that I can mess up its whole settings for testing every arrow shifting possibility. Thanks again!

You are very welcome.

The test file attached to my post above will hopefully be of some help.

Slàinte mhòr.

Just opened your test file, thanks for that – yes, the first blind text paragraph expands over the whole length while the seconds stays at the left side. I guess I’ll figure the rest out by myself, however, what I’m ideally trying to achieve are not such very, very long lines over the whole white area, but still limited - nevertheless staying in the middle, meaning that the left and right blank white area stays the same percentage (“symmetrically” speaking) even when making it wider. Hope it’s understandable what I mean, English is not my first language … :slight_smile: However, I guess this also is possible by dragging those arrows in the correct position left and right as “frontiers” – if there weren’t so many of them … :slight_smile:

Anyway, I’ll figure it out. Thanks a lot again for the help and the text file!

Hi.

The white part of the screen represents the paper. The black part of the screen is just the background.

The white part of the screen can be centred against the black part of the screen, using the Paper Position settings, but that doesn’t have any impact on the text inside the white part of the screen if it is restricted by a narrow margin.

If you want to centre the text in the white part of the screen / the paper, the only way to do that is to use Format > Paragraph > Centre, but that will make the text look jagged on both sides, which is probably not desirable.

In Scrivener > Preferences > Appearance > Composition mode, you can change the Editor Margins, but these aren’t dynamic, so they won’t scale when you resize the Paper Width in Composition Mode.

If you don’t want to change the margin as originally proposed, you might try changing the Text Scale (in the lower left corner of Composition Mode) as that will at least make things a little wider (though also bigger, which, again, might not really be very desirable).

Sorry not to be able to give a perfect solution.

Slàinte mhòr.

Thanks a lot again for the answer. Yes, as already mentioned above, if you consider the white part as a virtual paper sheet (which it represents) this is the “logical” behaviour. Was hoping that there’s a setting for my preferred view nevertheless as Scrivener is such a dream with all its setting possibilities. Anyway, this only is minor and I’ll figure the rest out – I don’t set the white “paper sheet” part THAT wide as in my demo picture so I’ll be fine. You’ve helped me a lot with hinting to the neccessary settings, thanks again!