Full screen setup in S2

Hi!

Thanks for the brand new S2!

Got a small problem with the Full screen set up: even though I selected full paper width in the preference panel, it still opens in a 1/3 width mode. Did I forget to set up something?

Thanks!

Remember the preference panel, kind of like the editor preferences, is an initial configuration thing. It won’t wipe out every single project preference you have. Many of the appearance options for full screen are meant to be project specific, because different projects may require different approaches. Thus we wouldn’t want to wipe out existing project settings with global preferences. All these do is configure new documents. To set your paper width for the existing project, use the control HUD at the bottom of the screen.

Yes, but…

When I close the full screen after enlarging it to 100% with and reopen it, it’s once again got a 1/3 width, which didn’t happen in S1.

Not really a problem anyway…

Thanks for your answer!

I think you misunderstood. The full screen paper width preference, as made clear in the preferences panel, affects new projects:

It’s a default setting. You control the paper width for existing projects using the control bar (which appears when you move the cursor to the bottom of the screen in full screen mode), just as has always been the case.

Hope that helps.

All the best,
Keith

Hi, seconding the thanks for an awesome S2.0!

I’ve noticed a related problem. When I enter Full Screen with no selected backdrop image selected, the “Background Fade” button works just fine. But when I enter it with a selected backdrop, the “Paper Fade” slider does nothing.

I’ve played with it in Full Screen mode, as well as in the preferences. And in upgraded as well as new files. No love. Am I misunderstanding, or is the paper supposed to become more transparent?

The slider fades the paper over the image when a background image is selected; if no backdrop is selected, the slider fades the background.

Hi Keith!

I think I did get the “New document” stuff all right… I’ll try to explain once again what I already tried to explain in my second post:

  1. I open the full screen: 1/3 width.
  2. I drag the cursor on the bottom of the page to 100%.
  3. I go back to normal mode.
  4. I reopen the full screen: 1/3 width again.

When I did that sort of things with S1, the width stayed just as I decided 2 seconds ago…

Thanks for your help!

Great, that’s exactly what I had hoped it would do! Unfortunately, the opacity of the paper doesn’t change, with adjustment of the slider. I’ve tried several 2.0 documents and a number of different background files. The paper stays at 100% opacity at all times. The other aspect, changing the background fade when no backdrop image is selected, works perfectly.

D’oh! A bug-fix I had made to something else a day or two ago has indeed messed up paper-fading. I’ve just nailed this down and fixed it for the release version, thanks.

I still can’t reproduce the problem with the width not getting saved still though, sorry.
Best,
Keith

Testing this out, I can reproduce the problem with the full screen width. It only happens if I adjust the width FULLY to 100%. When I do that and then exit to normal mode and then return, the paper size has returned to the 33%. However, if I resize it to something else, say 75%, and exit and return, that stays and is persistent through changing documents, etc.

Thanks for the clue, Mimeticmouton!

It also works for me! The thing is to avoid 100% width!

All the best!

Oops! That means I need to fix the documentation, as I went on and stated that the paper slider is disabled when a backdrop is in use. :slight_smile:

A-ha! Thanks for figuring out the specifics… And wow. That was a retarded mistake in the code. I have it set up internally so that if you set the screen width to full size, the width gets saved as -1 as a clue to Scrivener to max out whatever the width of the current screen is rather than using a specific width. But I’d also added a check that told it not to set the paper width if it was below 400 pixels wide. So the full screen width never got called. D’oh!

I’ve fixed this for the release version next week, and in the meantime the not-quite-full-width-workaround should work fine.

Thanks again!

All the best,
Keith

Thanks for fixing it!

And all the best for the fine tuning stuff!

Thank you guys for working so hard on this! You’ve earned your fans.

I hope that the “fadeable paper over photo backdrop” thing is something that ends up working out. I’ve already picked out a few photos I want to use! :slight_smile:

Best wishes on the bug-stomping…

Taja - sorry if I wasn’t clear, but yes, it’s fixed for Monday’s official release.
All the best,
Keith