Full-screen toggle; command-Z

  1. When toggling between full screen mode and the regular view, adjusted window layouts are lost as soon as I toggle. So, using command-control-F, I go to the full screen view, I have to mouse around to Window>Layouts> and then the saved layouts if I want my windows back.

Returning via the same toggle to regular view, the same thing is necessary to remedy the shrinking it does.

  1.  I saved my layout for full screen screenplay, but this layout does a couple of funny things: a.) it gets rid of the red line at the top of the red and blue index card I've selected, and allows me to scroll up endlessly, and it hides the top two lines in the Binder and the top two lines in the Editor. I can only see what's up there if I scroll and hold them manually - as soon as I let go, they're gone. This only happens with my saved Full Screen layout.

Is there a way for Scrivener to default to the saved window layouts in stead of going back to the defaults?

  1. When there is more than one Scrivener project open, and command-Tab is used to go to another program, when I return, Scrivener decides which project to bring to the front, and it's not necessarily the project that was open when tabbing away. 

Separately, it would be nice if command-Z to undo were available in the Binder after moving something. I bet you have a good reason why this is, and I’ll probably be embarrassed at not having seen it somewhere.


Hi Brian,

I’m not quite sure what you mean here, could you explain further? Just leaving full screen should return you to normal mode with the same set-up, unless you launched full screen mode using a layout, in which case returning to normal mode will restore its previous layout.

This sounds like a bug that should have been fixed for the next update. Please try downloading the beta version here and see if that addresses it:


Unfortunately this is out of Scrivener’s hand - OS X chooses which project to bring to the foreground. If you command-tab out of Scrivener with a project in full screen mode and command-tab back, for instance, OS X doesn’t move back to full screen but shows the project that’s at the foreground on the current screen. I find this behaviour annoying myself, but as I say, application-switching behaviour is handled by the operating system.

For various technical reasons, the binder undo stack gets cleared when the document in the editor changes. If you lock the editor so that the document doesn’t change there while moving things around in the binder, undo continues to work. It’s down to the way everything is interconnected and the fact that in Cocoa, undo works at the view level rather than the data level, so once something has been swapped out of a view, the undo stack that was working with it becomes invalid. Fortunately there’s a way to change the undo stack for text views, so that each text has a separate undo stack, but sadly this isn’t possible for the binder; or at least, I haven’t yet found a way of doing it that doesn’t cause many more problems. I agree that this would be a good improvement for the future though.

Thanks and all the best,

All right, one more time, with feeling!

In this first screen shot, a screenplay is open, and displaying in a saved layout named ‘Compressed Screen’.

Then, toggling with control-command-F I get the following:

I then use another saved layout, called Full Screen Screenplay, to get this (this is the one with the top lines sucked up and out of sight under the tool bar):

Toggling back, I get what would be the next image, a screenshot of of Scrivener with the Editor too narrow, and the Inspector and Binders wider than in the first above. So, to remedy that, I have to use the Compressed Screen saved layout that I started with. In other words, Scrivener is not toggling back and forth to what was last in, but to whatever some kind of other defaults are - I hope that makes sense…?

I will try the beta and report back; understood on the OSX limitations; and thanks very much.


Fourth screenshot - this is the way it looks after the toggle back from my adjusted Full Screen layout. I then use the saved layout to return to the first screenshot in the series in the last post.

This is not that big a deal - I just thought you’d like to be kept posted.



Hi Brian,

Ah, I see what you mean. This is expected behaviour, I’m afraid. The window is being resized to something smaller when leaving full screen, and in the second layout you have a wider binder and inspector. So when you come out of full screen and the window resizes, it will keep using that layout and the binder and inspector will stay wide (when resizing the window, the binder and editor widths stay constant).

You can work around this, though, just by selecting the “Full Screen Screenplay” layout when not in full screen. This will load that layout and move you into full screen automatically, and leaving full screen will return things to how they were before you entered - this is a feature when you move into full screen using a layout, as doing so tells Scrivener that you are using a special layout for full screen and so it assumes you want to restore things when leaving full screen. If you enter full screen before changing layouts, then Scrivener makes no such assumptions.

I hope that makes sense.

The bug whereby the top lines disappear should be fixed in the beta version, I hope.

Thanks and all the best,

Ah-ha, yes, I see that that does work…, sort of, because the choice for custom layout instead of going to full screen has to again be selected.


Sorry to be so annoying. No need to respond - I’m unbelievably happy with Scrivener.

Sorry, you lost me. :slight_smile: Which part is falling down for you? If you use the same layout in full screen, by the way, you can set it as the default full screen layout - then that layout will be loaded whenever you hit the arrows in the corner of the window to enter full screen.

All the best,

I’m afraid this doesn’t work for me… The custom layout that I have saved for Full Screen has the FS icon next to it in Layouts, but when I use it, it does not give me the saved layout. It gives me the one with the wide Editor as pictured in No. 2 above. Nonetheless, clicking on the expansion arrows in the upper right hand corner just gives me the fat editor.


That’s just a full-screen layout - it hasn’t been set as the default full screen layout yet. Ctrl-click on it and tick “Use Selected Layout When Entering Full Screen”. The arrows will turn blue to indicate that it will be used as the default full screen layout.

I’m not quite sure what you mean by the rest, though - the second screenshot matches the settings in your “Full Screen Screenplay” layout, doesn’t it?

All the best,

Fantastic - fixes everything. Now, when I take your earlier advice, start with my narrower screen custom layout, then go to Full Screen and back, everything works perfectly.

No, in the second screenshot, the editor is wide and the inspector narrow - but it’s all straightened out, and I can’t tell you how much I:

  1. Appreciate your attention and effort.
  2. Wonder how many hours are in your days.

I have been touting this software to everyone I know. Really the best ever.


Thanks! And glad that helped!
All the best,