Fullscreen background won't change

I had my fullscreen editor background set to a very nice typewriter sort of thing. And then I changed it to be my new book cover, just to see what that would look like. It looked terrible. Nice cover, bad background.

Anyway, now no matter what I do, it won’t change back. It stays as my cover. I tried deleting the cover from the project, deleting it from my hard drive. I reset the background numerous times. I even tried setting it to a solid color with no texture. It doesn’t change. Always that damn cover.

Anyone ever experienced this? Is there a fix?

Just a thought - have you tried closing and reopening Scrivener? Sometimes these things get caught in memory.

Yep, I have actually closed and opened it many times. I’ve been stuck with the bad background for weeks. I only today just got annoyed enough to post the question. :slight_smile:

If anybody’s interested, I found a solution to this but it seems like a bug.

If I set the full screen background from the Tools > Options > Appearance menu, it had no effect. The background did not change.

But if I set it with View > Full Screen Backdrop, then it finally changed normally.

Don’t know why there are two menu options to achieve the exact same thing, one of which doesn’t work. But there are. :slight_smile:

Hello DMSinclair,
“If I set the full screen background from the Tools > Options > Appearance menu, it had no effect.” That is because that setting sets the background colour for fullscreen without a background picture loaded. It is for a plain coloured screen, and it does work. It is just that that setting is not for changing the background picture.

But there is an option there as well for “Choose Texture” that lets you load an image file. That’s how I originally had my fullscreen background applied. It does the exact same thing, if the image you choose is big enough and iif there’s no background selected under the View > Full Screen Backdrop menu option.

Thank you for posting the solution. It was driving me nuts that I couldn’t enable my new image in the place where you would expect it to be enabled.

I get it that ‘view’ is more like toggle or selector, but I didn’t even know those options were there. I’ve always done changes in options and/or IN full-screen mode.