Fullscreen jumps away from original position

I have been using fullscreen mode quite a bit lately, and it is ideal for my needs; cuts out distractions etc., and I can even pick an independent zoom level to make the text a little bigger.

However, I have noted a minor annoyance to do with the position of the cursor or the page.

If I have, say, a 2000 word article at fullscreen (i.e. big enough that I must scroll) and my target paragraph is at the bottom third of the screen, when I click to place the cursor on my target (perhaps to paste some text in), the page jumps - as far as I can tell the default behaviour is to make the target sit in the middle of the page.

This can make things hard to follow. When I click on the page it can jump around, and I then have to relocate my target paragraph, which may have jumped up or down from its original location.

Is there a way to just freeze the page when it contains a lot of text? That is, the system seems to move the scroll bar to place the target in the middle.

Format > Options > Typewriter Scrolling. This is turned on by default for full screen, so just turn it off while in full screen. You can turn it off for new projects you create, too, via the Full Screen Preferences.

Thanks, worked a treat. Now it is perfect :smiley:

Glad it helped!

I believe the same thing is happening for me, even with Typewriter Scrolling off.

I’m working on a document in full screen mode. The curser and the screen are in the middle of the document somewhere. When I go to scroll up or down a little bit, it jumps to the very top of the document. Again, I’ve turned off typewriter scrolling and it’s still happening – it’s not that while typing the screen jumps (this is what I understand typewriter scrolling to do), it’s while using a two-finger scroll it jumps to the top.

Update: It actually seems to happen only when I have just switched into fullscreen mode. Not once I’ve begun typing. So to reproduce: have a long document, be typing in document mode. Switch to fullscreen and try to scroll a little bit. For me it jumps to the top of the document every time.


Are you on the latest version? I recall something like this being reported before, but I thought I’d fixed it. I’m not at my development machine at the moment so will have to check the history tomorrow, but let me know the version of Scrivener you are on.

Ack. Had the same problem, just read threat higher up and found menu option hidden under Format (> Options > Typeweriter Scrolling).


IMHO, this belongs more intuitively under “View.” Especially since the option exists as a preference, which is then ignored!

Just hand over the typewriter, nice and easy… :slight_smile:

The preference setting in the preference pane is the default for new projects. It won’t affect pre-existing documents.

My post from above is with Typewriter scrolling off – not only in preferences for new documents but also in Format>Options>Typewriter Scrolling. (I tried my best to do my homework).

My version is the latest – 2.0.2

thanks for looking into it!

Ooh yeah, I get this too, same as Nicholas. It only happens if the full screen mode is set to “no scroller.” Then when you go into full screen (starting with the top of the document not visible) and try a two-fingered scroll, up or down, it jumps you to the top of the document. It happens with both a single document and a Scrivenings session, jumping you to the top of the first document. I get it even after I’ve been typing in the document in full screen, but it only happens the first time I attempt to scroll–once it jumps to the top, scrolling after that is normal.

I encounter the problem as well, especially when doing proofreading: When I correct spelling in fullscreen, and the line break therefore changes, the document sometimes “hops” to a new position (centering the cursor or whatever), annoyingly confusing me since I have to search the cursor position again and former sentences are not at their former screen position anymore. Typewriter scrolling is disabled.

Wouldn’t it be possible to disable auto-centering completely, even if I then would have to work at the bottom of the screen all the time? Would be much better …

When typewriter scrolling is off, auto-centering is disabled completely. Any other behaviour is just part of the OS X text system and out of my control.

Absolutely no hope of fixing this extremely annoying “feature” Apple tortures us poor proofreaders with? It is almost impossible to do proper proofreading in fullscreen … always my eyes have to jump to the center and search for the last sentence I read when I have reached the bottom of a screen and press “Arrow down” for the next line …
The screen even jumps up or down a line when I just insert or delete a character that changes a proportion of the sentence.

Maybe Macs are not designed for writers …

Have you turned typewriter scrolling off?


Working is near impossible … is that really the same with other Mac users? I am quite despaired …

(Running current version of Scriv)

Inserting or deleting single characters even leads to document jumps right over half of the screen.

No light at the end of the tunnel? Does anyone else encounter similar problems? Or how do you manage proofreading with such a nuisance?

In the end, it is a kill feature (at least for me) … which would be more than a shame considering that everything else is close to being perfect …

I don’t blame literatureandlatte, I am just curious whether I have to add a really really angry point to my Mac OS X rant (against macs, not Scriv, sure)

You just need to turn of typewriter mode (Format > Options > Typewriter Mode). It keeps the currently-edited line of text at the centre of the screen; useful for composing, but not so much for editing.

Can you perhaps post a short screencast of this happening? I can’t reproduce anything like what you are talking about. You’re saying that when the paragraph is at the bottom of the display, say, and you add a word so that word-wrap changes, the whole buffer shifts up or down? I see nothing like that—I mean, naturally if the word wrap changes and a line is added to the paragraph, a line is added to the paragraph, but the position where I am typing does not shift. My eye does not have to jump around and find where the text went that I was just editing.

I mean, unless the spot that I’m typing in isn’t even on the screen. Then of course the buffer will shift no matter what so that I can see where I am typing. This seems to be absolutely reasonable to me, so I’m sure that is not what you mean.

Sure, I will try to do a screencast. Says more than a thousand words :wink:

I PMed you the DropBox link!
Above is the Typewriter Scrolling button, TS disabled.
Then change into fullscreen mode.
Then arrow up/down.