Fullscreen shifted up on 90º screen

When in ‘full screen window on secondary screen when possible’ mode, the writing area on my secondary 24’’ HD screen (Rotation 90º - portrait orientation) is moved up, so I cannot access the upper part of the text while the bottom part of the screen is black. Even when scrolling. Overall it looks like the whole working area is shifted up.

More, I tried to use my 90º oriented screen as the main-and-only monitor, and in full screen mode the same happens - the screen area is shifted up.

Is this a bug? Could anyone confirm that full screen is working properly when monitor is rotated 90º?

Thank you.
p.s. Except for this, Scrivener 2.0 is great.

Which version are you on, the NaNo version or the full release?

While in full screen mode, move the cursor to the bottom of the screen so the control panel appears and then hold the Option key down. You’ll see the “Width” slider turns into a “Height” slider. Adjust that - it sounds as though it’s not set to full height - the paper stays in the top third of the screen when the height is reduced.

It does sound like a bug though, as the height shouldn’t change when you rotate. I can’t reproduce it though - I just rotated my 24" monitor 90 degrees, and full screen was fine (you didn’t rotate while in full screen mode did you? I suppose that could have done it). I did fix something related to this since the NaNo version, though, so if you are using the NaNo version that may be the explanation.


I have the same problem although my secondary monitor isn’t at 90 degrees.

I’m running Scriv 2.0 on a Macbook with a secondary monitor screen. Full screen mode works fine on the MacBook, but when I try it on the second monitor the text only appears in box at the top of the screen, about a third of the screen height. I’ve tried pressing option and adjusting height, but only works within that limited range - it doesn’t extend page height across the full extent of the screen.



Again, which version are you on? The NaNo trial or the full version that was released this week?

Sorry - full version.

Does this happen with new projects, too? Or is it just with an updated project? Were you running in the NaNo version before, or did you never use that one? Did you try adjusting the slider in the control bar - does that fix it?
Sorry for the barrage of questions, I just need to be able to reproduce it.

In the interests of science I just tried this and I too get odd results.

If I set my second monitor to 90 degrees then the top 1/3 of the screen is unused and unaccessible and the paper extends below the bottom border (the height slider still has some way to go when the paper hits the bottom edge).

I tried this with both a project I’d converted from 1.54, and a new blank project I created freshly in 2.0. In both cases the problem occurred.

This only happens on my second screen. On my primary screen, everything appears as it should (or at least, as much as a man angling his head 90 degrees to the left can tell!)

OS X 10.6.4, Mac Pro
2 screens, both running at 1920x1200
Scrivener 2.0 (6076)

Supplementary info:

  • Graphics card is an ATI Radeon HD 4870
  • No output on the console when doing this test
  • If I rotate 270 degrees, the problem is still apparent, just the paper goes off the other side of the screen


You mean with both monitors turned on with stuff on them? I don’t seem to even be able to test this - my Displays system preferences don’t offer me the option to rotate my secondary monitor if I have both displays on; I an only rotate it in clamshell mode. Anything special I need to do?

Oh hang on - I’ve just reproduced something similar, only mine went off the bottom of the screen on a non-rotated secondary screen (after rotating it). Working on it…

Ah, cool - I think you found it then :slight_smile:

In case you didn’t and you’re doing it some other way, System Preferences -> Displays. Both monitors should have individual windows where you can set the rotation independently.


Hi again,

Still struggling.

My system prefs > monitors is set for separate windows. The second monitor is oriented normally (e.g. landscape).

The problem occurs with both new and updated projects.

I haven’t run NaNo, but upgraded > 2.0 yesterday.

The slider changes the size of the visible page, but it still doesn’t extend the page more than a third down the screen.




I think I’ve found the bug. The paper was using screen co-ordinates rather than window co-ordinates for setting its position, so if the bottom of the second screen is higher or lower than the main screen in the system preferences, the paper was still getting set based on the position of the main screen. I’ve fixed this for the next build - I’ll post it some time tomorrow.


Nice one :slight_smile:


You rock!