getting main scriv window instead of last project

So…I’ve been using scriv without a hitch for over a year now (and yes, my version is up-to-date). On the advice of the brains here, after encountering that strange “you’re using an older version” error message I’ve been zipping up my files before quitting and happily, when I open scriv, I’m always returned to the place where I stopped (and that error message hasn’t returned).

Except for today (when, of course, I’m nearing the end of my book). Today I opened scriv and instead of looking at the last page I worked on I’m looking at the scriv main window, asking me if I’d like to start a new project, open an existing one, or view the tutorial. So when I go to “open existing” I’m confronted with a list of my zip files which I can’t open (they’re not highlighted).

a) is there a way to open the zipped files? (Surely!)
b) Why am I getting this main window all of a sudden?
c) (Less pressing, but curious) why are the zipped files smaller (in terms of MB) than the non-zipped ones?

Thanks so much.

c) the zip are compressed. think vacuum packing a sweater. It is a bit more complicated, but the idea holds. Not sure of your level of tech-headedness so forgive what may seem to be a simplistic analogy.

b.1) sounds like your either your prefs are getting corrupted (KB would need to comment) or maybe the file was moved. Scriv can’t find it so it says “How about a new one?”. You might want to look at the console log for any errors.

b.2) you might be getting ready for a bad experience. back your data up as soon a you can then use disk utility to verify that your drive is ok. You can also look in system log for any reported errors.

a) Yes there is. Not at a spot to check, but I think you can unzip the archive. I am sure someone will give you much better instructions that I can muster off the top of my head.

z) do a spotlight search for your project. if b.2 is wrong (which I hope it is) then you should be able to find it.

To open a zip archive file, just double click on it in the Finder like you would anything else. There will be a brief progress bar (maybe not so brief if it is a large project), and the contents of the zip will be placed into the same folder in which the zip archive is. Find that (it should just be a single Scrivener project) and double click on it to load it.

After you’ve inspected the project, you can safely delete it. The original zip file will not be touched when you double-click on it. It’s like a magic box that will keep producing copies of its contents every time you double click. The copies are expendable (unless of course you make changes to them!)

Jaysen and Amber:

Thank you so much for your prompt and helpful replies. Loved the vacuum-packed sweater analogy and “you might be getting ready for a bad experience”. Hilarious. Scary, too, but hilarious and apt.

I figured out all by my lonesome how to open the zipped files (but thanks, A., for the lesson re copies – I was very confused re that) and ran the disk utility on my hard drive and external drive – all’s well there.

My project is well backed-up, I believe: I back it up on the hard drive, on the external drive, and on a USB drive before I finish work each day.

A couple of loose ends remain:

  1. What means “console log” and where do I find it? (For the record my “level of tech-headedness” is about as pronounced as the head in Jaysen’s photo.)

  2. Should I be worried about my prefs being corrupted and how to check? (KB?)

  3. I am no longer getting that “how about a new one” message and haven’t had a problem finding my project so far (ok, once, but I figured it out and it hasn’t happened since I started zipping the project, though that may be coincidence).

  4. I still don’t know why I’m getting the main Scriv window when I open instead of just being returned to the page I last worked on. As per other topic threads, I backup and then quit without closing and up until now it’s worked just fine – I’ve always been returned to my last stopping point.

So please let me know what I should do next, how much I should be freaking out, etc. Again, cannot say enough good things about this program. And if I had a nickel for every time I’ve pushed it on another writer…

Click on the Finder in the Dock, and then from the “Go” menu choose “Utilities”. I can’t remember if I hacked that in, so if you don’t see Utilities, choose “Applications” and then search in that window for a folder called “Utilities”. In that folder is a program called “Console”. It gives you a little window into all of the messages that the many applications on your computer write to the disk, or what are also referred to as log files. Much of it will be highly technical, but sometimes you can get an idea of what is wrong by searching for the name of the application that is misbehaving. Not all applications “talk” to log files though. Scrivener is one that does.

I wouldn’t worry too much about it. Periodically save out your preferences using that “Manage…” drop-down at the bottom of the preferences pane. Keep these in a safe place, and if you ever have to trash your preferences in the future you can load all of your settings from that file.

I’ve only had my preferences go corrupt a handful of times in years, and I’m probably not a good case for what is normal as I’m often running multiple versions of the program at once, some still in various stages of development.

It sounds to me like your problem was solved, so I wouldn’t worry too much. It’s not a bad idea to run Disk Utility once a month or so. It can at the very least, alert you to small errors which can grow to be larger errors down the road. Chances are it’s just the preference file. I recall seeing an error much like this before on the boards—Scrivener just seems to lose track of where it was, and resetting the preferences helped.

Thanks again. Followed all of your instructions.

Curiously, the console only lists messages from the first of the year to April 15 but…I’ll assume everything’s ok? I saw nothing about Scriv in there, or at least not the word “scrivener”.

So on restart Scriv is now back to its old self, opening at the last page I worked on. Weird.

I wish I could send you some cookies as a thank you, Amber. I bake a mean brownie!

NO log entires after 4/15? Make sure you have “All messages” selected in the left pane. If you still have no entries after 4/15 you might want to consider a quick trip to the apple store for a checkup†. You should have a few entries just from regular use.

[size=75]† There are a number of things that could cause this, but if your tech-head and my head are similar as you suggest it would probably be less frustrating to have someone look at it. There is likely nothing wrong, but the symptoms that you note, and the missing log entries (if you do in fact have “all messages” selected) would send me into a heightened state of alert.††[/size]

[size=70]†† How is it that my foot note contains more actual content than the message? Bah![/size]

Dear Jaysen:

OK, I did all that and located some entries from today. Good. No trip to Apple store. Thank you again.

Glad to hear it. While the apple store can be … occasionally fun, it is normally the quickest way to the dog house. Or counseling. Depends which bone headed move snort (the Mrs (search the archives if you really want to know)) remembers.