getting rid of tab settings copied to Microsoft Word for Mac after compiling.

Hi, I’m trying to get rid of all the tab settings that seem to be copied to the Microsoft Word document (either .docx or Office 2004) when I compile it. I’ve checked my Word settings, and that’s not the problem. This has been a long-standing problem so I don’t think it’s related to my OS (11.1).

When I compile into a Word document, Scrivener gives me a first line left flush, which is great. Scrivener then obligingly indents all paragraphs, except for the first paragraph. Also great. What’s not great is that I have a zillion tab settings that appear in the Microsft word document after compiling. I don’t use tabs as they drive editors insane. So every time I compile a document I have to go back and clear the tabs in the Word document. Sometimes I forget and that’s really annoying.

I’ve tried to get rid of the tabs by using the dummy text box in Preferences > Editing > Formatting. I’ve also tried setting up another dummy text box in a new project and then using the User Formatting in Current Editor button. None of this seems to work. Every time I compile, the tabs appear. I’ve tried to use the Project → Project Settings → Formatting pane to do this by formatting a scene in the way I want, but the pane is grayed out. Any ideas?

Have you tried using Documents > Convert > Text to Default Formatting after you’ve removed the tabs in the Preferences? Changes in the Preferences only affect new documents.



If the tabs are not present in the Scrivener editor but are present in the compiled document, then probably the Compile command is putting them in. Look at the Formatting pane for the specific Section Layout you’re using.


The easiest way to generate clean formatting is to modify the compile settings for paragraph formatting. Generally, no amount of changing the writing environment (the two preference areas you mentioned) is going to make a difference in what the text looks like—unless you use a very basic compile setup that essentially just passes through formatting. That said, removing tabs stops from your default writing environment certainly wouldn’t hurt, and it sounds like you don’t need them anyway, so I see no reason to revert the settings you’ve already made. To fix the output though:

  1. Enter File ▸ Compile…
  2. In the central preview column, locate the layout that prints body text, and double-click on it to edit the format. If you have more than one, just double-click on any of them, you’ll be taken to a place where all of these are configured anyway.
  3. So at this point you should be seeing the culprit right in front of you. Here for example is what the default ruler looks like for the “Manuscript (Courier)” compile format:

Click anywhere in the sample text. The first thing you want to double-check is whether this formatting is coming from a style or not. Click the little ¶a button, and if anything is checked off here, then you actually need to go over to the Styles pane and fix the ruler there—but whether you do it here or there works the same.

  1. Use the Format ▸ Paragraph ▸ Remove All Tab Stops menu command.
  2. So long as you don’t have any other Layouts to edit, (and if you fixed this at the style level, and all of your layouts that print text use a central body style, then you may not need to), click the Save button and give that a test compile.

That will fix body text—you may note if you click around a bit in your word processor that empty lines or other text may still have tab stops. If you really want to eradicate all of them, you’ll need to repeat the above steps for all sample text in Layouts or Styles.

I’d also double-check with your editor to make sure they really care about this or not. What you say is true in that generally you don’t want tab stops being used to fake indents, where one hits the Tab key every time they start a new paragraph as they might on a typewriter. That’s a good rule of thumb in the publishing industry, and probably what you’ve seen being warned against. Scrivener won’t be using tabs to adjust paragraph indents though, as you’ve probably seen at this point. But just having latent tab stops in the paragraph settings really hurts nothing, and most word processors will have some set up by default.