Global change: increase new paragraph indents

I liked the way my document looked in Scrivener, but when I compiled it and sent it to Kindle, the indents seemed to cut in half and you can barely tell where new paragraphs begin. How can I globally increase all the new paragraph indents throughout the whole document? I tried in doing it via preferences/formatting, but it limits what I can change there (for example, I can’t choose a new typeface–it stays in “Cochin.”)
Thanks!

First of all, you can change everything about the formatting in that preference pane. The font controls have been condensed down into a single button since they wouldn’t all fit in the smaller window. Click the “A” button to set font family, variant and size, or simply use the Mac standard, Cmd-T with the cursor in the text. It’s also worth noting you have access to the main Format menu here, too. But, as you may note in the bold text at the top of this pane, this is a default for new documents. You can go back and update old documents to a new default, using the Documents/Convert/Convert Formatting to Default Text Style menu command.

Alternatively, another way to control output formatting is with the compiler itself. It has its own “Formatting” option pane. You would want to click on any of the rows here in the top half that have a “Text” checkbox enabled (on the right) and set things up there, after clicking the “Override text and notes formatting” option at the top of this pane.

This is already helpful, thanks. However, when I change my defaults and then try to convert an old document TO the defaults, it only changes the portion of the document I’m looking at at the time. I click on “Manuscript” and then select the “convert” option, but it doesn’t apply any changes globally. Obviously, I must be doing something wrong.

This command works on a document selection. If all you have selected is the root draft folder then nothing will happen. You need to select all of the items you wish to convert. You can use Shift-click to select entire ranges of documents from the original highlight to the point you clicked on.

Thank you! So intuitive, yet somehow I missed it!

New issue–I have fixed ALL the indenting issues and the manuscript looks perfect when I go to compile. But upon compiling for Kindle, I find that the second paragraph in MOST (but not all) scenes (or “documents,” in Scrivener-speak) is NOT indented, even though it clearly shows as being indented in the Scrivener doc. For the record, I set my paragraph indent in formatting, then converted the entire Scrivener document to default text style. THEN I went through and removed the indent manually from the first paragraph in each scene, but didn’t touch anything else. What am I missing? Thanks!

Since you mention the problem as being sporadic, the best troubleshooting move is to make a comparison between the two that are producing different results. A likely thing to check is invisible characters. Toggle those on with the Format/Options/Show Invisibles command and check these initial paragraphs against other paragraphs. Do they use the same symbol at the end of the paragraph? Are some of the paragraphs adorned with tab characters instead of using indent formatting? But just keep an eye out for anything differences. Are they at different levels of indent in the binder? Are the checkboxes the same in the Inspector, etc.

I’ve had the same problem. I did check invisibles, and sure enough, the correctly indented lines have no blue arrow beginning them and the incorrect lines — those that should be indented but aren’t — have the blue arrow. I have no idea why some lines differ from others, however! When I typed up my manuscript, I tabbed all of them. So, is there any way of globally fixing the problem, so that all lines indent properly?

Another aspect of this: I’m using a Mac, and I have the Kindle Mac program installed on it. When I open up the ebook on my Mac, all of the indentations look as they should— they are all there. But when I open the same compiled ebook on my iPhone or iPad, the lines with the blue arrows don’t indent.

All right, that’s one potential problem that can be discovered with invisibles on. The arrow line is of course a tab character, which shouldn’t be used for indenting.

The other common problem is the presence of a little down-and-left arrow on the end of a line, meaning there is a line break, which is different from a paragraph break in that it operates inside of the paragraph. It’s a way of breaking a paragraph into multiple lines—hence such features as first-line indent are ignored for the subsequent lines because they are not the first line of the paragraph. You’d get an indent for the “first” paragraph, but not the “second” because both are the same paragraph (technically speaking), if that makes sense.

Yes, click on the Draft item itself in the Binder, switch to Scrivenings view (it may take a few seconds to build all of the text into the editor), and then use the Format/Convert/Strip Leading Tabs command. You may want to apply first-line indent universally when compiling, too, in the Formatting pane (the E-book preset will do this for you).

Tabs are something you generally want to avoid using for anything other than stuff like tabular content or odd formatting conditions (for example where you need left and right aligned text on the same line), and they should nearly always be avoided in e-book publishing, as various readers do not handle them well (Nook & Kobo for example will render the whole book without word-wrap if paragraphs are tab-prefixed), or just ignore them.

Thank you, AmberV. Now all I have to know is how to indent without using the tab key. This must be really simple, but I can’t figure it out!

Here are the settings from the compile window:

Amber, I don’t know WHAT’S going on. I’m including the Scrivener “invisibles” view and then the Kindle previewer view so you can see that the second paragraph just will not indent. Help!


Everything looks fine from the editor. What do your compile settings look like? I’m assuming you aren’t using “Override text and notes formatting” in the Formatting pane, since you’ve gone through the trouble of setting all of this up by hand. If that’s on, you may want to turn it off.

Another thing to check is the “Options” button beside that setting. There are some things here that can clean up formatting, or set how that is done. One of them is to remove indent on first paragraphs. You might as well switch that off it is is on. Just keep things as simple as possible.

Well, turning OFF “remove first paragraph indents,” even though that’s technically what I want, seemed to do the trick. Somehow it was also turning off second paragraph indents. So now I’ll go through and manually remove all the first paragraph indents and it should be fine. Thanks for suffering through that with me:)

All right, that’s the approach I would take as well. I wasn’t going to suggest it since you had already done the hard work of setting the indents manually, but going back to them not being indented is at least easier since you have the convert formatting tool. I would be sure to make a backup of your project in its current state before making this transition. No sense in wasting hours of work if it still causes issues with the second paragraphs for reasons we have not uncovered.

Just use the File/Back Up/Back Up To… command to create an independent backup somewhere handy.

Amber, thank you for your help. I still have one problem remaining, however.

I am able to get the indentations in my Kindle output to work properly, but when I do so, the file shows everything in the same font size, which is not the case in my manscript. Also, I have one superscript that I would like to use, but the numeral is not raised. If I turn off “override text and notes formatting” I do have control over font size and superscripting, but I no longer have the indents! How can I keep the indents, but not override font size and superscripting? I tried clicking on various buttons that show up after clicking on “options,” (Compile/Formatting), with no success.

Sure, if you switch off compile override formatting then you’ll need to handle every detail yourself in the editor. Just make sure the indents are applied in the editor and you should be fine.

Okay, thanks. But just to be clear, because I like using “override text and notes formatting” to do the indents: if I do use it, there’s no way I can also have differently sized fonts, or employ superscripts, in my compiled Kindle ebook?

There is a lot of grey area, yes, but what tactic you will take depends on the nature of your formatting. For example, if you have long sections in a secondary font (say, journal entries in the middle of a novel from one of the characters), then the best device to use there would be to hold the journal entries in their own files in the Binder, and set the “Compile As-Is” checkbox in the Inspector. This will force the compiler to use the formatting of the document instead of the compiler override. It actually goes a bit further than that—it disregards everything in the Formatting pane, so if it would have had a Title it won’t with As-Is on, if it wouldn’t have printed text, it will anyway. It just completely ignores all of those settings, and is thus very useful for stuff like this, where you have a significant chunk of text that needs to be “different” somehow.

A more fine-grained tool is Format/Formatting/Preserve Formatting which you apply to text selections much like you would bold or any other formatting. This will draw a protective zone around the text—a bit like saying “As-Is” for this text only. A good number of the options you see in the Formatting pane regard how much preservation that feature does. This feature is going to be better for smaller chunks of text that need to be different, like block quotes, sub-headings and so on. Note it saves into Formatting Presets. You can set those up to include PF from the start so that both the formatting and the protection is applied simultaneously.

Finally there is tweaking the options you already discovered in the Formatting pane, but as you note there isn’t an option for precisely what you want: leave the fonts alone but fix everything else.

As for superscripts, I don’t see that getting lost in the Mobi output with either override on or off, but the font size does change, which can diminish the clarity of it. Preserve Formatting solves this problem as well.

I tried this, because all I need to do is change 4 spots: switch from size 12 to size 10 font for excerpts that are 4, 8, and 10 lines long, and increase from size 12 to size 20 one line. It looked very cool with the borders around the excerpts, but unfortunately, the text in all cases did not change after compilation, and looked exactly like the rest of the manuscript.