Global Search Strange Results (False Positives + Other Peculiarities)

Hello,

When I search for I.D. with the “Any Word” Search Option, I get 1 hit (which is actually I.D. followed by a comma in the text) as well as 2 false positives. (Specifically 3 documents pop up in the binder, but I.D. is only in one of them. )

However, when I search for I.D. with the “Whole Word” search Option, I do not get any hits at all.

(When I search the compiled manuscript in acrobat pro, there is only one instance of I.D.)

I cannot figure out the logic behind this. So any help much appreciated.

Penelope

P. S. I am working with a huge manuscript (350K words) in case this makes a difference.

What is the search scope? Do you also search in notes, synopses, and snapshots?

Have you tried searching for an EXACT match with a space after the last period - "I. D. " (And/or adding a space before the “I” - " I.D. ")?

How do you search (only) in snapshots?

If I have a certain word in a snapshot, but it has been deleted in the corresponding document, then this snapshot is not found. Is that different for you?

You can search in Snapshots through the Snapshot Manager.

The text will not be in the search results when it’s deleted from the original document, it might be in Titles, Text, Notes, Synopsis, Keywords, Labels, Status, or Section Types, when these are included in your search scope.

Ah, the Snapshot Manager, good tip, thanks. Unfortunately, the search is limited to one word. Not very convenient if you have a lot of snapshots. But better than nothing. :slightly_smiling_face:

Hello again.

So many responses in so little time! What a wonderful forum! Thanks to everyone who took the time to respond. (BTW I’m only a few days into scrivener and it has me awed by its possibilities—and simultaneously disillusioned by its quirks. That said, I think I’m firmly committed. And with a little help from this group, I expect to slog through ridiculous issues like this one! )

The search scope, search operator and search string were not the problem.

But there IS something weird going, and taking snapshots reveals its behavior exquisitely. (Thanks, AntoniDol, for this hint!) None of the false-positive search results showed up when I searched for them in the Snapshot Manager. Therefore, it seems to me that there are “ghosts” remaining in the binder documents that get stripped out when I take a snapshot of them. And these “ghosts,” I’ve discovered, are words that I have previously replaced using Edit=>Find=>Project Replace. [Update: I’ve been testing this and “Rolling Back” the snapshots does not fix the problem—i.e. the “ghosts” remain in the document even after having been “viewed” as a snapshot. Apparently the snapshot viewer simply filters them out. And this makes sense if the snapshot is simply a shortcut to whatever’s in the binder. The problem is the “leaving in” of the replaced words. Said more simply, Edit=>Find=>Project Replace doesn’t seem to “Replace” words at all. How can this be true?]

This creates a huge dilemma for me. I planned to use Project Replace to make the spellings of place names, etc. consistent throughout. And I have a lot of work to do in this regard. (Please recall that my document is 350K words.)

So what to do? Has anyone opened up the RTF’s associated with scrivener’s documents and examined them? (I’m assuming that they are easy to find.) Are they safe to edit or am I going down a rathole here?

Is there any hope of getting this behavior addressed by the Window’s scrivener coder? From my reading of other posts, Literature and Latte seems a tad lackadaisical about addressing bugs. And this issue has the potential of being a big one. It certainly has huge ramifications for me. Therefore, any help from the forum navigating my dilemma would be greatly appreciated.

Thanks again,

Penelope

I have no desire to be polemical. Just the facts. Other app gets an update every few months or weeks. Either bugs are fixed or small new features are added. How is it with Scrivener?

Definitly a rathole. Scrivener is the interface to change these files.

I see no reason not to use Project Find and Replace to straighten naming issues out.

Try rebuilding your search index. It’s a long shot, but can’t hurt and might help

File > Save and Rebuild Search Indexes.

image

The RTF’s are in your project folder, within Files > Data, stored in uniquely named folders.

Best to close Scrivener before viewing them in an RTF app. Do NOT edit Scrivener’s RTFs outside of Scrivener, as that has high risk of corrupting the file.

My guess is you’ll find that the Project Replace has in fact replaced the words in the RTF file and that your issue is due to something else.

Best,
Jim

1 Like

Dear Antoni,

The problem with this approach is that I can’t tell whether I actually addressed a required spelling change or not. For example, I decided to use the spelling “dialog” rather than “dialogue” throughout the 350K word manuscript. So I used Project=>Find and Replace to do this. But a few days later I decided to double-check to make sure it had been done. (This scenario describes exactly how I discovered this odd behavior in the first place.)

When I searched for “dialogue” the second time I figured it would not be found. But it was. So I assumed that I hadn’t made the global replace earlier and began clicking on the hits to see the instances I had missed. But the pages displayed didn’t have any highlighted text in them. Does this make sense? (Please tell me I’m crazy and there’s a simple fix!)

Perhaps you would be so kind as to try this yourself. If I’m correct, the search results for previously replaced words will be documents with no highlighting in the text—i.e. what I call “ghosts” or false-positive results.

Thanks,
Penelope

1 Like

Thank you, everyone. It seems that Jim’s “long-shot” suggestion to “File > Save and Rebuild Search Indexes” worked. Hallelujah! (Perhaps my large project size will require that I do this. We’ll see…)

Now I can get back to work. Good thing, too, because I was entertaining the thought of going back to Microsoft Word, and that would have been very unfortunate indeed.

Thanks ever so much,
Penelope

1 Like

Not really.
The underlying framework on which Scrivener for Windows is developed is limited in many ways, which would sound rather pathetic to have to excuse every day.
An unreadable picture of issues was shared a few months ago to demonstrate the volume of Windows issues compared to Mac.
That said, I’ve been anticipating an in-version Windows issues list revision, since L&L ported the app to the latest Qt framework between March and July 2023.
In terms of searching a string like I.D. you could use ID in the editor and replace it with I.D. in Compile Replacements.
Where I come from saying, “May I see your ID document?” is perfectly acceptable in a script. Everyone knows what an ID Book or ID Card is.

1 Like