Good morning -- compile question

While I love writing in Scrivener 3, I find compiling in it beyond difficult and am struggling to figure it out. Right now, I’m trying to compile a project to publish an e-book on Amazon. I prefer to write in double spacing because it’s much easier to edit that way, I want to publish in single spacing with paragraphs indented. I spent more hours that I want to report–most of a day-- trying to figure out various other aspects of the compile and was successful, but I cannot figure out how to make it output to single spacing with paragraphs indented. Any help would be gratefully appreciated.

When you are setting up compile, when setting font etc for the text, simply click the Format in the top menu, as if you were in the Editor, and change line and paragraph spacing.

As lunk says, when you are in this place shown below in compile settings, Format > Paragraph > Line and Paragraph Spacing brings up those parameters for the format-setting paragraph pictured there. You can also just pick your linespacing from the (familiar) pop-up menu noted here, or call up the whole dialog box by choosing Other… off that same pop-up.

Thanks for the screenshot. But I think that’s what I’ve done.

I’ve attached 3 screen shots and labeled them. Unfortunately, I added them so they’re in reverse order.

With both of the output files I used the same setting as the compile screenshot.

Any suggestions as to what I’m doing wrong?

Thanks for your help

Down at the very bottom, where it says “text and notes use default formatting?” That’s the problem. You need to override the Editor formatting. See GR’s screenshot.


At the bottom, you tell Scrivener to use the default formatting. Change to ”override” something (don’tbremember the exact wording)