Green dots underline

I’ve suddenly had the occasional green dotted underline appear under a word in something I’m working on.

I believe this indicates a grammar checker finding something awry, but as far as I know I’ve always had the grammar check options switched off. Certainly the Prefs/Corrections/Check-grammar-with-spelling-in-new-projects remains unchecked, as ever, and the (menu bar) Edit/Spelling-and-Grammar popup has only Check Spelling While Typing ticked, again as ever.

So why the green dots?

That’s what green means, but I’m not sure why it’s grammar checking if you don’t have the option enabled. If you load the spell check panel itself (Shift-Cmd-;) is the checkbox enabled? It shouldn’t be if the menu is unchecked, but that’s one other place where it can be set.

Oh there is also a blue underscore under a single word now and then, I think that indicates that a word has been auto-corrected. I don’t know for sure as I always have that feature switched off.

AmberV, thanks. I checked the spellcheck panel, and indeed the Check-grammar box there is unchecked, too.

Bit of a mystery, then.

I do have autocorrection switched on and see those blue dots after it corrects something. I did wonder if I was going colourblind, but apparently not. (And I’m in two minds about autocorrection: it’s helpful when it picks up typed fumbles; it’s annoying when it “corrects” to something you don’t want. Currently the former just about outweighs the latter, so it’s on for now.)

Well, no sign of the little green dots today. Maybe the blues ones grew some moss. It can happen this time of year.