hang on add snapshot

OSX 10.7.3, scrivener 2.2 (15858) (from website, not apple store)

I have a project with the draft of one of my novels in (~90k + notes). It is set up to sync with an external (dropbox) folder, so most of my scenes have a handful of snapshots. Today I discovered that if I attempt to take a snapshot by hand (either by kb short cut or by clicking on the snapshot bar), scrivener hangs and has to be quit with ctrl-option-esc.

From top’s output, scrivener is using <1% cpu, so its not trying to do anything else. I’ve tried rebooting the machine (still broken).

I then created a new ( fiction novel, w/out parts) file and tried to take a snapshot and it still hung!

I appreciate this is insufficient to debug the problem, but I’m not sure what additional data I can provide. If there are logs or similar I can trigger, then let me know and I’ll do so.

[EDIT:] console.app shows nothing.


Scrivener redirects its console output so that it can be included in automatic crash reports. To get the log data, please do the following:

  1. In Scrivener, from the “Scrivener” menu, select “Reveal Support Folder in Finder”.

  2. Now take a snapshot so that Scrivener hangs.

  3. In the Finder, in the folder that was revealed in Step 1, drill down into the “Logs” folder and open Console.log, either in a plain text editor or by double-clicking (which will open it in Console.app).

  4. Please copy and paste the contents - if any - into your reply.

Whats particularly confusing here is that you are getting hangs when taking snapshots in a brand new project.

Thanks and all the best,

Both console.log and console.log.bak are empty, I’m afraid. Going to try an uninstall/reinstall later today, see what that does.