Has anybody noticed that the text size of the find and replace screen is comically small?

here ya go…

Thanks for the screenshot.

So ok, it is unrelated.

Which Windows built are you using ?
10 – 11 ?

Windows 11 home. I need to take my photo into a photo manipulator and shrink it. It always enlarges when I post on here, making the text seem bigger than it actually is.

Off topic, but to save you some trouble, you can always resize it afterwards. (If you are good with maths and proportions.)

image

Greetings from across the pond. How do I know? Maths!

Yeah, I could take it into Gimp and do that but It seems we have zeroed in on the problem. It’s a tiny bug so I’m assuming it will be low on the list.

edit: oh, I see what your saying. I wouldn’t even have to take into Gimp. I could do so in the theater of the upload screen. Gotch ya.

1 Like

Could be this is due to high resolution displays with a high scaling setting.

If you’re on a higher resolution display of, say, 2560 × 1440 or 3840 x 2160, you will typically boost Windows scaling up from 100%, so text is large enough to be readable.

So perhaps the bug is that the ‘find text’ interface element doesn’t respect the Windows scaling setting. That is, the ‘find text’ remains at 100% scaling even though Windows scaling is set to 175%. If so, then these are the symptoms (tiny text) I would expect to see.

My display resolution is 1920 x 1080, too low to test this theory. But @GoalieDad or @Puffysmoke – please set your screen resolution low enough that you can read all the text on your display comfortably at a 100% scaling setting. With that configuration, if the ‘find text’ interface element text is the same size as the text on the rest of the Scrivener display, then I think that would prove this is the cause of the bug.

I’m just suggesting this as a test, not a workaround.

Best,
Jim

1 Like

As Vincent_Vincent pointed out, it is not just the text of search fields, but also the title in the header bar and possibly other GUI elements as well. I have the same issue, the only solution to get readable fonts is to go back to the default theme:

2 Likes

I indeed am using the default theme…

I am using Dark Theme and have no problem. I’ve used most of the other non-default themes recently and had no problem. The theme may be a factor, but it is not the only factor.

Particularly because this screenshot shows the problem while using (what appears to be) the default theme.

1 Like

changed to one of default themes, with no apparent change, my base resolution is 2560 by 1440 and then changed to 1600 by 1024. will show high res first then low res


Thanks @GoalieDad, but what’s your scaling? Set your scaling to 100% please for each res and show us screenshots.

So –

Set 2560 by 1440 at 100% scaling and take a screenshot.

Set 1600 by 1024 at 100% scaling and take a screenshot.

ETA:

Actually, a better test would be:

Set 2560 by 1440 at 100% scaling and take a screenshot.
Set 2560 by 1440 at 150% scaling and take a screenshot.
Set 2560 by 1440 at 175% scaling and take a screenshot.

(If 2560 by 1440 is not your normal high resolution, then use your normal high resolution for the test.)

That would demonstrate which UI elements are respecting the scaling changes and which are not.

Best,
Jim

1 Like

Was 150% as seen on screen but will do later before Eagles game- Fly Eagles Fly

1 Like

Here at 100% zoom, not seem to make a difference.


Don’t change the Scrivener setting “zoom”, change the Windows setting “scaling”.

In Windows 10, it’s Windows Settings > System > Display.

You should see the Scaling setting near where you change the resolution.

Here you can see my display resolution of 1920 x 1080 and scaling of 100%.

image

This worked for me. I had scale set to 175 and resolution set to 2469x1664.

1 Like

JimRac all my shots were at a resolution of 100%. I went back and checked and misunderstood and thought you meant zoom.

@GoalieDad, no worries!

The workaround for this will impact your entire Windows configuration, so it may or may not be worthwhile for you. For @Puffysmoke it was worth it, as the text was too small to read. For you, maybe you can live with it until it is fixed.

If you want to try it, then first write down your current settings for Resolution & Scale. You’ll find them in Windows settings, as per @Puffysmoke’s post above.

The tweak is to reduce your Resolution & Scale settings. Try making the smallest changes to each that you can. The closer Scale is to 100%, the closer the ‘Find Text’ will be in size to the text in the other UI elements. (Although you don’t need to go to 100%–see @Puffysmoke’s post for what he did.) You may need to reboot to see the impact on all your apps.

Your other option, of course, is to uninstall Scrivener 3.1.4 and reinstall 3.1.3, which didn’t seem to have the issue.

Best,
Jim

thanks, I will live with it, my screen resolution was 100% already. I will stay with 3.14 due to fact use PWA everywhere which is more important than the smaller text in the find dialog, till they get a fix.

1 Like

It’s baaa-aaaack. Weird. My settings are the same and the text is minuscule.

I’m having this problem too. It’s my labels and status.

I will say that back on Scrivener 2, I had this problem en masse when Windows did an update. It didn’t go away until Scrivener 3 came out. It was so bad that time that I actually stopped using Scrivener (gasp, right?).