Headers and page numbers

Hi all. It is with deep humility, and after messing with Compile and a lot of Googling that I must ask for help with headers and page numbers.

I wrote a short story, which is a gift for a friend. I’m using the short story template. I added a cover letter to the front matter. This clearly Messes Things up; the easiest thing to do would be to delete the cover letter. But I’d like to understand how this all works and to bend Scrivener to my will.

The cover letter means that the first page of the manuscript is now page two, and it has a header. I want the first page of the story, which is page two of the project, to be numbered page one and to have no header. Headers (starting with page number 2) should start after the first page of the story (page 3).

Please include instructions on exactly where to find the menu option because my memory isn’t what it was and was never great to begin with.

Stay well and safe.

What version of Scrivener are you using? Some people are still on version 2 for Mac, and that makes a big difference.

You know, I just went to reply to this post, and accidentally reported it.

Here’s what I meant to say:

Scrivener 3, and woah you guys are good. After I posted this question, I found the answer myself. It’s in page settings under the compile window.

But I give you all the credit. I’ll remember to say Scriv 3 next time I post.

Small follow-on question:

At the top of the manuscript first page, after my cover letter, there is a section separator (#) and some blank space. I’ve found the Separators options in Compile formats, but I haven’t been able to find the right way to make that hash vanish.

Maybe I’ll find the answer right after I post this.

If you’re customizing the section layout formats, make sure you know which formats you’re using, then find the corresponding separators in that section of the compile setup. There you’ll be able to change what it uses to separate adjacent documents.

But if you’re using “front matter”, and you give that document a different section type (the right pane when you bring up the compile window) from the story documents/folder, then you may not get a set of hash-marks between the front matter an the story. Those marks are intended to go between “scenes” in a chapter, rather than between a forward and the first page of chapter 1, so you probably won’t have to do any other customization.

Just keep in mind that section types (visible in the inspector, or the outline view if you enable that column) are “what this is”, so it’s helpful to use the most appropriate section types, or create your own. If you have 1 document for front matter, and one document for your story, then that needs 2 section types, which I’d want to be “front matter”, and “story doc”.

A layout/section format is “what a thing should look like”. You get to decide at compile time what a “front matter” document type should look like after compile, and to have a separate look for your “story doc”. Just use the Assign Layouts button in the middle pane of the compile window to set that up.

Well, OK, now I’ve made my headers vanish entirely. Two steps forward…

I’m going to give the project a rest while I wait for your answers.

When assigning section types to layouts in the compile window, be sure to link up the right layout (with or without headers) to the right section type (front matter vs story document section types). Do your front matter and story documents have different section types assigned to them?

That is a good question. My options for section types right now are “Structure Based,” “Scene,” and “N/A.” Which should I be choosing?

I’ll admit that I’m completely unclear on how to create layouts and how to link them up to section types, even after doing a lot of reading.

Here’s a very rough example. I used the paperback compile preset so I had more options to choose for folders and “scene” documents. Hopefully examining it will illustrate what I’ve been talking about.

I didn’t create any layouts, mind you, though I did go to Project->Project Settings and created section types that made sense to me.
FakeShortExample.zip (98 KB)

Thank you for your example. I have created new section types, but I can’t see how to assign them to a section layout in the compile window. I think that may be my fundamental issue here.

Edited: You’ve given me lots of good advice, but I’m still lost about the entire process of getting from what I have now to pages numbered correctly and headers where they are supposed to be and not where they are not supposed to be, and I may remain lost until I can get a walkthrough on the process.

I removed the cover letter. Now either I have headers on every page whether or I want them or not (If nothing special or different is checked under Compile → Edited Project Short Story (Times) → Page Settings


I have no headers if I check “Different header and footer on first pages” in the same place.

How to I change my project so that it has headers on the second and following pages?

The “First Page Header” under “Front Matter” is set to type “N/A,” which is what I believe it was to begin with.

To make things simpler, I re-did the project with a clean copy of the default formatting. The cover letter is in place, and the headers start on the second page, properly numbered.

The remaining problem is that there should be a page break between the cover letter and the rest of the manuscript, and I can’t find a way through the compile layouts and formatting to make anything happen between the cover letter and the rest except for a #.

Can you tell me what to do to create a page break after the cover letter or before the rest of the manuscript? Changing the settings for section separators does not change how the separator between the cover and the rest appears after formatting.

Correcting the appearance afterwards in LibreOffice just gets the page numbers wrong, and I’d rather learn how to fix it in scrivener anyway.

So, when you bring up the compile window in Scrivener 3, you get something that looks like this:

Once you click the Assign Section Layouts button, you get the following window:

On the left side, choose one of the section types. Then scroll through your choices, such as the one shown, which will insert a page break, and then just add the “section title” (the binder name of your folder or document). In my example the folder is where the “story” would get it’s name and make it start on a new page.

Then I’d choose the “scene” section type, which is where the text of my story (in my example, there are 2 scene documents in the binder), and scroll through the options to find something that only included the text (not the titles).

You may want to review the following video and the next 2 that come after. Or start the Scrivener Tutorial and skip to the section “Get It Out There”. I think what you’re struggling with here will be cleared up with one of those sources.

Here are a couple of problems I’m having (but new problems!)

In the short story compile format, there are only a couple of section types. I switched the compile to use manuscript format, which gives me many more section types.

There is, however, no as-is section type that does not start with a page break. Thus if I want the cover letter to have as-is formatting, there will be a page break before it, kicking everything down to page two. How do I assign a section type that does not begin with a page break?

On the other hand, I’m assigning the front matter item a type that begins with a section break, but the compiled document does not have a section break before the front matter item. If only I could get the page breaks to switch!

I know that my project is organized differently than yours is, so I am including a screen shot of the compile window in case that makes a difference.

My brain is too old to learn from videos, but I’m going to go read the tutorial part that you recommended again.

If you don’t see the Section Layout you want, you can edit an existing one and/or create a new one. Edit the Compile format and go to the Section Layouts screen.


Note that the Manuscript formats are, unless I’m mistaken, set up to mimic common submission guidelines (double-spaced lines, 1" margins, Times New Roman 12 point font…). You may find the Paperback presets more to your liking for what is essentially a self-published work.

Note that the page break is for folders only in your screen shot. Your letter is a document (the icon in the binder for “Cover Letter” is clearly not a folder icon). So you should be fine.

By “front matter item”, I assume you mean the document titled “First Page Header”? If so, assign it to a “Front matter” section type (you may have to go to Project->Project Settings->Section Types to add one before you go into the compile window). Then when you bring up the compile window, click “Assign Section Layouts”, choose your new Front Matter section type, and find a layout that includes a page break before it, with or without the document title, as you prefer.

I believe the Paperback format has a “New Page” format that might work. It has “Page Break” at the beginning (but doesn’t specify Folder Only), and uses the text formatting from the document in Scrivener.

That’s very helpful. It’s nice to be able to name specific documents, folders, etc… rather than speaking in generalities. Scrivener is flexible, but that means that there are a plethora of ways to organize your binder, a lot of choices to start your compilation setup, and a number of other options beside that which can affect your output.

Thanks everyone. I gave up on getting the cover letter to do what I want for now and will bundle it separately. But I’ve learned a lot here, and I think it will be useful. Many blessings on those who took the time.

As a bonus anecdote, I’ll tell you a story about another powerful but even more complex piece of writing software from back in the day–Wordstar. It used formatting codes just like you’d expect these days from LaTeX. Making it do what you wanted was a black art, and you couldn’t tell for sure if it worked unless you printed the document on your dot matrix printer. I read an article in a major computer magazine where the author was unable to get something to work after a couple of hours on the phone with Wordstar support. It turns out that they were trying to get page numbers right. But the term used was “pagination.” Pagination is not page numbers. But apparently the article writer didn’t know that, and neither did the Wordstar support person.

If I’d had to print everything out yesterday to see what happened, I’d have gone through a lot of dead tree.