Help: How do I get rid of tables?

Today I copied some text from another app and when I pasted it in Scrivener it appeared in a table cell. No matter what I tried, whenever I pasted the text it appeared in a table. I even used Textedit to convert the text to plain text, then I copied it and pasted it in a new document and still I got a table.
I got pretty desperate and tried to find some way to convert the table into text but I couldn’t find any information on it. I googled, I read the manual, I looked in the Take Control of Scrivener 2.0 book, but I couldn’t find any reference to tables (especially on how to get rid of them.

Why has this happened? How do I get rid of tables?

If you right-click in the text that’s in the table, you should get a “Table…” option in the context menu. Select that, then in the new window that pops up, set the rows and columns to 0 (zero) and it will remove the table.

As for why it happened, it’s likely that the other application used invisible tables for formatting and so that copied along with the text but came out a little goofy in Scrivener–I’ve had that happen a lot, emails being a particularly nasty culprit. Pasting with Paste and Match Style (Opt-Shift-Cmd-V) might help avoid the problem if that’s the cause, although it will also strip other formatting like bold and italics, so it may not be the best option for you.