Help! Scrivener won't open!

I have Windows 7, and after I’ve uninstalled the previous versions of Scrivener and installed the latest today, Scrivener won’t open at all. I’ve tried uninstalling it again and installing it, and restarting and turning off my computer, but nothing seems to help. The Scrivener icon (which I’ve pinned to the Start menu) lights up, then fades gradually until it looks like no windows are open in it. I’ve tried clicking the desktop shortcut, opening a project file, and everything, but nothing works. I’ve also opened the Task Manager, and looked at the processes tab as I open it, but it just disappears from the processes a few seconds after I click it open. Please, please help! I want to edit my novel! :cry:

Hi lilyiris,

This is definitely an odd one. How did you upgrade–from within Scrivener using the Help>Check for Updates menu or a manual download and install? I’m wondering if there might’ve been something that glitched in the download process, although it seems unlikely if that were the case that the program would’ve installed at all. Still, it might be worth a shot deleting the Scrivener directory entirely (not your projects, of course, which should be safely stored in your Documents folder or elsewhere outside of Program Files) and then downloading afresh and installing again: … taller.exe.

Another thing that might happen, although I haven’t reproduced this yet so it’s only theoretical, is if a project that Scrivener is trying to open when the program starts, according to the preference settings, has gotten corrupted and is crashing the program as soon as it tries to launch. If that’s the case, you should be able to get Scrivener to start by breaking the file path it’s following to the project–try moving the .scriv folder to another location and then double-click the .exe to launch Scrivener. (If you know which project Scrivener might be trying to open–it would be the last one you had opened when you lasted worked on Scrivener, or maybe the one or ones that was open when you updated, if you updated from within the program–you can just move that folder; if you’re not sure, and you keep all of them together in the same place, try just moving the bunch of them. You want to move the entire .scriv folder, not just the project.scrivx file you use to open the project.)

One other thing I just thought of–if you’ve just been trying to launch via the shortcuts, make sure they’re still pointed to the new install of Scrivener. I’ve had it happen that shortcuts don’t always update when you reinstall, so it’s possible that the program’s fine and it’s just the shortcut not accessing it. Try also going into the Scrivener directory under Program Files and launching it directly from there.

Thank you so much! Your reply got me thinking on the right track, which was that my file was corrupted. I tried a number of ways to de-corrupt it (none of which would restore my settings), until I finally decided to start deleting the documents that had been most recently saved before the autosave apparently crashed. I deleted “docs.checksum,” tried to open my project for the zillionth time, and poof! All of of my settings and documents were restored to their previous glory! Yay! Thanks for your reply! :smiley: Now all I have to do is finish writing the dang story…

Glad it’s working again! I would like to figure out why/how the project got corrupted, though. Did Scrivener crash or your computer have a hard shutdown or anything else odd go on when you last worked on the project? Are you working live from Dropbox or another sync service? Obviously this isn’t something that you should be running into, so it’d be good to know what caused the file to be corrupted.

The same thing happened to me and I followed the moving the file instructions and voila! Thank you! I have a laptop with Windows7 and one night I had Scrivener open still when I shut the lid. When I came back the next morning my laptop had rebooted for updates. That’s probably why it didn’t open. Oh well! It works now! Thank you so much! :slight_smile: