Help — Space as text icon makes Scrivener crash on right-click and I can't change anything

Hi,

I wanted a transparent icon so I thought I could make one with space as a text icon but hell no, it made Scrivener load indefinitely and now I’m stuck.
The thing is, I can’t suppress it now : each time I right-click, it freezes (even in the “Documents > Change Icon” menu).
I tried to look in Settings/ui.ini but I can’t find anything here.
It’s so dumb ! :sweat_smile: Help, I can’t right-click !

1 Like

Here is a no-icon icon for once your issue is fixed. (This one is not a gate to hell.)
You just drop it in the icon folder in your project’s folder. After which it’ll list along the other icons.

zzzzz NoIcon.zip (4.7 KB)

. . . . . . . .
As for your current issue :
If you can’t change the icon but the project opens, copy the text from the problematic document to a new document and then delete the faulty one ?
If you have snapshots you want to preserve, you can export them via the snapshots manager…
Or create new snapshots in the new document via a good couple of manipulations…

Thanks, but that’s the same thing if I open a new document.

I think you should open a support ticket with the techs from LL.
This is something they might be able to fix, if they can go to where in the project’s guts it says what document uses what icon.
(And I am pretty sure they’ll at least want to know about the issue.)

I don’t think us mortal users will be of much help.

Bonne chance.

I just messed around with one of my test projects, and I am pretty confident I can guide you to fixing yours.

You’ll need to know the exact name your document has in the binder.

. . . . . .

[EDIT] Nevermind. I spoke too soon. My test project is destroyed.

1 Like

This is major.
It is not the project that is corrupted… It is the software itself. None of my projects work any longer.
I’ll have to reinstall.
A complete reboot didn’t help.

@MimeticMouton @AmberV

@VagabondFrog If you haven’t already, find your project on your hard drive, zip it and place that zipped copy of your project somewhere you’ll later easily find it if needed. (Do not trust Scrivener to zip you a backup of your project. Do it yourself, manually.)
I would advise that you don’t do much else Scrivener-wise until you ear from LL.

1 Like

[REPORT]

After a complete reinstall all is fine.

Even the project that caused the issue to begin with works as it should.

CONCLUSION :
Whatever trying to use a space as a text icon did, it did to the software and not to the project as it would seem at first look.
When trying to first fix my test project, I saw that the icon listed was still a standard image icon. (But that’s in my case, because that’s what the document had for an icon previously, and not the default icon.) ← My point being that your project is likely fine.
You’ll have to save your preferences (whatever you do do not right click anywhere, use the top menus only) and then reinstall.

This is not LL official support. I am just a user, not affiliated in any way.

2 Likes

Hey, thank you for your dedication anyway :face_with_hand_over_mouth:
I will try. Yeah, my project is not corrupted, everything is fine.
I have to save my preferences at least.

Well, no luck today. Reinstall didn’t work. There has to be some cached data somewhere.

Did you uninstall first ?

As in uninstall, reboot, install.

Yes, that’s what I did. It didn’t wipe my prefs or ask me for my license (but maybe this one is always stored in registry or something).

Then lets try something a little bit more on the safe side.

Whatever you do, do not right click. Use only the top menus functions…

  1. Open the problematic project.

  2. Select the document that caused this.

  3. Create a new document. (Ctrl-N)

  4. Go back to the problematic document and select all text in the editor.

  5. Copy paste it in the newly created document that’s just below it.

  6. Select then move the faulty document to trash. Document / Move To Trash.

  7. Project / Empty Trash

  8. Quit Scrivener.

  9. Uninstall, reboot, install.

Normal

Not normal. You didn’t reinstall properly.

That’s what I did just before :grimacing: The text file with the faulty icon in the binder is not there anymore.

Ok that’s what I thought. But there’s no option to keep or erase everything. I’ll try again just in case

I tried to uninstall/install and now my prefs are gone and it works again. That’s weird.
Thanks @Vincent_Vincent!

Meanwhile, I opened a ticket. We’ll see.

1 Like

That’s a pretty nasty bug! The problem is that “Recently Used” icons are stored globally in the registry, which would explain why the problem spreads everywhere. It can thus be much more surgically removed in RegEdit (for those willing to do so), by deleting the following key while Scrivener is closed:

HKEY_CURRENT_USER\SOFTWARE\LiteratureAndLatte\ScrivenerQt6\RecentIcons

For future reference, how I would address this is to make a 16px PNG image that is completely transparent. That will give you a visual “space” . Here is an example:

  1. Download this .zip file: blank.zip (683 Bytes)
  2. Unzip the “Blank.png” file from it to some temporary location.
  3. From your project, use the Documents ▸ Change Icon ▸ Manage Icons... menu command.
  4. Click the + button in the lower left, and select “Blank.png” from the file selection dialogue.

The new icon will show up in the main custom icon selection menus at this point.

1 Like

Thanks for the info, that’s interesting.
Yeah I use a blank icon now :grin: