Help with page numbering (on some pages but not others)

I do apologise for the “beginner” question but, although I’ve used Scrivener for some time and have read the manual in much detail, this is a problem I simply seem unable to conquer. I’m sure it’s pretty basic stuff but some help would be very much appreciated.

I have front matter of a front sheet and table of contents. I don’t wish a page number to appear on any of those pages .I then have sections (call them chapter title pages, if you will) which contain an image and heading. I wish to include those in the numbered pages (i.e., when calculating the numbers of subsequent pages) but don’t wish to display a page number on them. Each of those is followed by sections, all of which need to display a page number.

I have been battling (for many hours!) with compile settings. In the main compile dialogue I have double-clicked on each section type in turn (having already created and saved a project format for this project). In each case I go to Page Settings > Header and Footer Settings and either include or exclude (as the case may be) the <$p> footer.

The problem is this. When I change the footer for one section type it also changes for the other section types. I’m clearly being obtuse and have done something stupid. If someone could tell me nicely what it is I’d be most grateful.


These are page layout questions which are better sorted out after compiling in your word processor or page make up software. You’re not going to be able to do such complex layouts easily, if at all, in Scrivener.


Thanks for that reply. But that’s a little sad as I really wish to compile direct to pdf.


I know this is old, and I share your unhappiness with the reply given. I spent hours with this on two separate occasions, because it’s not clear in any documentation as far as I can tell. To create pages for a PDF that are not numbered, do the following:

  1. Create a new folder for the project and title it “Front Matter” and/or “Back Matter” (if you have any).
  2. Move the pages/documents you wish to have no page numbers on to those folders, i.e. Title Page to “Front Matter”, in the order which you want them to appear in the final compile.
  3. At the bottom of the File dropdown, click on Compile.
  4. Compile for “PDF”
  5. On the right side, you see all of your files. At the bottom, check the box “Add Front Matter” (and/or “Add Back Matter”. In the dropdown next to it, select the folder you created called “Front Matter”. The files will be added to the top (or the bottom if Back Matter).
  6. Next, right click the Format on the left you are using and select “Edit Format” (if it’s a preset format you might have to select “Duplicate & Edit Format”).
  7. On the left, select Page Settings (toward the bottom).Under “Headers & Footers” Options should be preselected. Check the box, “Different Header & Footer on First Pages”. Make sure “Page numbers count first pages” is unchecked.
    8.) Just below that next to “Main body header & footer starts…” select the page number you want page 1 to appear. I.e. if page 1 and 2 are not to be numbered, set it at page 3.
  8. Instead of Options, click on Header and Footer Text. On the right you should see “First Pages” and “Main Body”. Here is where you put up what you want to see. In “First Pages” you leave out a page number, but could have any other header or footer. In “Main Body” is where you’ll want to put your page number - which is “<$p>” (or anything else you want to appear there, such as the title of the manuscript).
  9. Save it & compile.

You may have moved on to other less confusing platforms, but I put this here for my own use as well, because it’s easy to forget.

It’s really kind of you to go to the trouble of setting that out in such detail. I did eventually get there after some trial and error a while ago but I really appreciate the detailed and helpful response. I’m sure it will assist others facing a similar problem.