Hide ruler?

One document in a current project suddenly decided to have a hanging indent.

Searching for Scrivener help online I discovered that this mystery could be got rid of by changing the indent on the Ruler. Did it and it worked. But now I can’t get rid of the ruler. Cmd-R is supposed to be a toggle, but it isn’t working as one, and “Hide ruler” is not an item in the Formatting menu. Help!

You’re right that Cmd-R should toggle the ruler. Strange that it’s not working for you.

There is a command though; when the ruler is visible, what you’re looking for is Hide Ruler, which you’ll find under the Format drop down menu. I believe that when the ruler is hidden, this command automatically changes to Show Ruler.

Now that’s weird.

The Format drop-down was instead showing “Show ruler”, but greyed-out. But I went off and had a bit of lunch, sleeping the computer while I did it, then when I came back I opened a different project and did a bit of work in it. Went back to the ruler-ruled project, and “Hide ruler” had reappeared. Happy now.

Thanks for the help. Scrivener must have just had a conniption.

Funnily enough, the same thing is now happening here. Screenshot attached to show that my ruler is visible, but the command is greyed out. Cmd-R is not working either. What have you done to my computer :smiley:


Just switched app focus to Safari, then back to Scrivener, and all is once more as it should be. Weird.
Screen Shot 2017-11-06 at 15.45.34.png

What’s app focus?

I just mean when I use a different piece of software, the menu options in the tool bar change to reflect the app being used. So if I’m using Safari, I see Safari’s menu options. If I’m using Scrivener I see Scrivener’s menu options, etc.

That’s it. Thanks for clearing things up!

Nope. I was working in the documents within the project, but going “Grrr” because I couldn’t get rid of the ruler. However, it magically disappeared eventually, so happy days.