Hide/unhide ruler - Possible bug

Using Yosemite, Scrivener 2.6. Hiding/un-hiding the ruler via menu or short-cut works fine, but the text on the menu does not change, as it does with Hide/show format bar. Anybody else experiencing this?

Hide Ruler 1.png
Hide Ruler 2.png

It works fine for me. Where is the focus when you look at the menu? The focus has to be in the text view for the menu to show the correct setting, as it pulls it from the current first responder, so if your focus is in the binder or somewhere else, it may not reflect the actual setting of the editor (there is more than one editor, of course).

I did the test again. AFAIK the focus is on the text editor. The cursor is blinking there and then I move the mouse to the format menu. I tried it both full screen (Yosemite green button maximize) and in regular editing mode; and both in Scrivenings and single document modes. All with the same result.

In fact, I did a complete scratch install of Yosemite and Scrivener (the previous report was on a Mavericks upgraded to Yosemite). I did not change any of the default Scrivener settings to do the test.

Scrivener starts with the menu saying “Hide ruler” and does not ever change after selecting the option over and over, even though it toggles the ruler correctly. :confused:

Do any of the other Show|Hide dynamic menus display this problem? Try with View/Collections/Show|Hide Collections.

This one works as expected!