Hiding idea snippets from a draft


I wonder how I should keep a linear draft and sparse ideas in the same document.

What I usually do, when starting to write the linear first draft, after having organized my sparse ideas, is this:

  • Collect homogeneous snippets and ideas, fragments and citations, into a document. This will be one section of my project.

  • Start shaping the linear draft from the sparse fragments. Usually, I have the linear draft at the beginning of the document, and the source snippets in the second half of the document.

  • When I want to print my linear draft, I want the snippets to be excluded.

To do this latter, I can either mark them as inline annotations, or split them into a separate sub-document, and exclude it from compiling.

I prefer the first solution, since it doesn’t add clutter to the binder/outline. It’s very easy to do.

What I don’t know, is how to deal with footnotes and annotations I might have already marked in the snippets. They would be overwritten by the general marking as inline annotation of the second half of the document.

Maybe I should simply stop using annotations and footnotes in my snippets, and only start using them when writing the linear draft.


I use a character attribute style for that.
In the compile format’s styles panel, you can add that style and tell the compiler to remove text of that style from the output.

Compiles to:

1 Like

Vincent, this looks like the cleanest and most elegant solution!


1 Like

You can see it compiled with two spaces between “ideas” and “for”.
All you have to do is include one of the spaces in the character attribute style’s assignation in your text (in the editor).

I should have done it like that:

1 Like

The other way is keep notes in Notes folder mark as not compile and put links from ideas inside to the draft where they are used and remove links when compile

What I don’t like of this solution is that I wouldn’t have the flourishing text and its generating ideas together. In my mental process, it is really like drawing over a rough sketch.


Well said.
. . . . . . . . . . .

1 Like

YES thanks - This is a briliant solution - but please help me Vincent; When I select a text in the document (Windows - Scrivener and select a style, all the text in the entire document becomes that style - not just the selected text - what am I doing wrong?

There are character attributes styles that apply only to the text selection.
Then there are paragraph formatting styles. That apply – as the name implies – to the whole paragraph the cursor or selection is in, regardless otherwise of the text selection.
And third, there are styles (save all formatting) which apply to the whole paragraph, but with character attributes as well.

My best guess in your case is that you are using a paragraph formatting style, as opposed to a character attributes style.

If your whole document was somehow formatted as a single long paragraph, yes, a paragraph formatting style will affect the whole of that giant paragraph. Therefor, in such a case, your whole document indeed.

Are you using line-breaks instead of normal carriage returns, between “paragraphs” ?


All right! YES You’re right - when a select a style with the “special CR-symbol” as part of the part name, the whole text is being formatted - but when I select a style without the CR-cymbol - it works - thanks. But how do I edit my “Idea” style to NOT have the CR-symbol as first “letter” ?

That cannot be done. Once the style is created, it is too late.
You have to set it to be a “character attributes” style when creating it. It can’t be changed afterwards.

You will have to start anew.


→ Likely best to delete or rename that other style first.

Thanks Vincent - It’s really appreciated all the help you provide - have a great weekend!

1 Like

As always, double-click your Compile Format to reach the Compile Format Designer as seen above.

Hi Antoni - the picture is actually from Vincent’s post (his screenshot) - but in Scrivener 3, I can’t find the same setting panel - or am I completely wrong?

Sorry you’re right - of course - just double-click on the format - it’s gonna be a long day - LOL :grinning: