Hiding onscreen keyboard when using external keyboard on iPhone?

Perhaps this documented or discussed here, but I can’t spot it. If so, apologise for the duplication … but, in anticipation of a few transatlantic flights to USA over the summer, and the apparent plan for USA to ban laptops onboard, I’m setting up to use my iPhone with Scrivener an and external keyboard. The arrangement should keep me mildly entertained while on the flight! Anyway, with the external keyboard working, I find that the on-screen keyboard keeps popping up when I don’t want it to and I’d like to have a way to say “go away and stay away, please”. How to do this?

In my experience in using Scrivener on an iPad, this happens when I haven’t used the BT keyboard for a while, and the keyboard shuts itself off to save its battery. Just tapping a key on the BT keyboard takes the onscreen keyboard away, sometimes after a few seconds for the iPad to detect the keyboard again. This is using a Logitech Ultrathin Keyboard Cover with an iPad Air 2.

Of course your setup is already different in that you’re using an iPhone, and a different keyboard as well might render the above irrelevant. But perhaps it’s worth checking out.

In any event, I know of no way to prevent iOS from popping up its onscreen keyboard when it’s editing text and it can’t find a hardware keyboard, but I’m willing to learn.

This may be a function of the quality / stability of the Bluetooth on your keyboard. I rarely if ever get this, using the Microsoft folding keyboard.

Interesting. I am using an Apple “desktop” BlueTooth (the small size model). I’ll look into the Microsoft one before travelling. I have three of those, and all seem to do the same thing.

It would be nice if there was a software setting–but it would probably be a system not Scrivener setting–to “rely only on blue tooth keyboard” or something.

Update. I purchased and using for typing this note a Microsoft Folding Keyoard. Nice. Light. I will be able to get used to it. But, it operates eactly the same when using Scrivener. When typing, the on-screen keyboard pops up and consumes a large part of the screen with no way to say “go away” that I can find.

The IOS Notes App does work as expected, e.g. the onscreen keyboard disappears when using the external keyboard.

A nice enhancemnent to Scrivener would be to have a way to put the onscreen keyboard away when using an external keyboard.

Grasping at straws here, as I agree that this is likely being caused by some bluetooth connectivity loss between keyboard & phone – but — are you by any chance using a custom keyboard (e.g. Swype or Word Flow) and not the standard iOS keyboard?

Asking because my recollection is that occasionally the Swype keyboard would interact oddly when I was using Scrivener with a bluetooth keyboard, so I always make sure that I have the iOS keyboard selected when I use the bluetooth keyboard.

Bingo! While slapping forehead, isn’t that obvious now. Yes, switching from Swype to the standard keyboard now allows the iPhone, Scrivener, and external USB keyboard (Microsoft foldable) to work as expected. I should of thought of that. Thanks.

I truly didn’t think that would be the cause, but I’m happy that it was! :smiley: