Hiding specific textfiles in scrivenings - possible?

While I am working in a scrivening, is it possible to mark specific textfiles so that they do not show up inside of the scrivening?

a folder with several subfolders inside the draft. Each subfolder holds several textfiles. Let’s say one of these Textfiles holds just some additional Notes that I do not want to be displayed if I work on the draft as a scrivening. Is there a way to “hide” it (so that it’s contents are invisible inside the scrivening)? or does it have to be relocated?

I don’t think so. I would create a folder called “Notes” or some such, outside the Draft/Manuscript folder (since presumably you won’t want them to be compiled anyway) and move those files into it. Then make a Document bookmark link between them and the other textfiles in the appropriate folders, set to open in the other half of a split editor or a QR window if you have the screen space…

That way, you don’t have to view them, but you can quickly open them in a split editor or QR window if you need to.



1 Like

Thank you Mark!
I was somehow hoping I could avoid just that ; )

Here’s another suggestion: move each one out of its folder and the Draft, keeping it just below the folder oin question. When you open that folder in Scrivenings view, it won’t appear. If you use Navigate > Editor > Lock in Place (Cmd-Opt-L on the Mac, don’t know the Windows shortcut) for your scrivenings, you can then select the notes in the Binder and use the spacebar to bring up a QR panel. Unlock the editor when you’re done with that folder.

Test.zip (22.3 KB)

For example.


1 Like

You can make a Scrivenings session with any selection of files, including a non-contiguous one.


If you right-click the folder in the binder and choose Open ▸ with Compilable Subdocuments, only the subdocuments marked for inclusion in compile will be shown in the editor. You can toggle off that option for the notes document you want to exclude by loading the document in the editor and clicking the image icon in the editor footer or deselecting Include in compile from the metadata tab of the inspector.

This will also mean (the real point of it!) that the notes document will not be included in your compiled output, even if it is in a group and given a section type that normally would. But you can easily toggle the setting again within the compile window if you do need to include it at some point.


Thank you so much for your help and the testfile you prepared.

This is a great thing to know. I had no idea this was possible.

Perfect! That is exactly what I was looking for. It makes things so much easier for me!

Thank you all for helping to finally figuring out such a wonderful solution for me : )