Highlight issue

Version 1.5 highlight issue

  1. In a new project and in normal view, type some text and press enter.
  2. Go up to Text->Highlight and pick any color in Arbitrary.
  3. Go back to Text->Highlight and turn off highlighting by clicking on the top checked option.
  4. Go into full-screen mode and up to Text->Highlight and the top option will be checked still. Uncheck it.
  5. Leave full-screen and re-enter it. Go to Text->Highlight and the top option is checked again.

Between step 4 and 5, if you type some text in full-screen after turning highlight off and press enter, when you go back to normal view, the highlight option is checked again.

You need to quit Scrivener to stop the process.

Hi Brathna,

Actually this isn’t really a bug, if I understand you correctly, although it’s not very intuitive either so I will add it to the list of things to look at. That is, it’s a technical limitation that I would need to work around rather than an outright bug - yes, I know that doesn’t make much difference to the user!

What is happening is this:

When you switch off highlighting without typing anything, all that happens is that the typing attributes get altered - no actual text gets altered. When you launch into full screen mode, the typing attributes are taken from the text immediately before the insertion point (because the full screen mode uses a new text area) - which still has highlighting there. So you have basically found a unique situation in which this doesn’t work as well as it should. As I say, I’ve added it to the list of things to look at, to see if I can grab the typing attributes from the current view rather than from the text without causing other issues. I can’t promise this will get into a 1.5x update, though.

Thanks and all the best,

I load up my story and go directly into full-screen. Select some text anywhere in the story. Then go up and select an Arbitrary highlight color to highlight my selected text. Go to the bottom of the story and type something. No highlighting because it’s off. Leave full-screen and re-enter it. Highlighting is now turned back on no matter if I’m on the same line as before or on a new line. It seems like a problem with Arbitrary highlighting and mode switching not remembering that highlighting is turned off. You can also replicate this problem using normal view as well.

I know it’s a small matter, but I was looking forward to something like Arbitrary highlighting because the other colors are too bright for my color scheme in full-screen.


I’ve run into a highlighting problem too; in fact, I’ve specifically logged on to the forum for the first time in a long while just to see if it was mentioned by anyone else.

In normal view, once I’ve selected an arbitrary color and highlighted something, EVERY new page where I start to write begins to automatically highlight. I have for instance created about fifteen index cards with plot ideas; even after turning highlighting back to none where it had appeared, if I click into any of the card documents and start to type (in the document itself), the highlighting is once again on. I have to manually un-select highlighting (toggle back to “none”) each time.

This doesn’t seem like it’s either intuitive or what could possibly have been intended.

For what it’s worth, though, I do enjoy being able to set my own highlight colors. Never could tolerate that ugly greenish yellow thing.


I’m also having this highlighter problem since recently updating to 1.5 . Every time I create a new file, the highlighting is on. Also, annotations are sometimes orange.

B DaCosta

The highlighting in a new project bug occurs if you have been using arbitrary highlighting and then create a new project. I’m not sure what’s causing it right now, but it is on my list to fix for 1.51, which will be a bug fix release for 1.50 available in the next couple of weeks.
All the best,


I’m having problems to highlight in any other colour than yellow when I’m in fullscreen mode…

is there any way to change that?