Highlighter Trouble

I don’t remember this happening earlier with the find menu, but right now, when I use the find function, it automatically highlights the words it lands on with the text highlighter. It stays even after I try editing. It happens in more than one project.

Is there any way to turn this off? I want to be able to search for a word within a specific document without necessarily highlighting it.

My highlighter color also keeps changing. I had it on black for a formatting thing, then switched it to green, and it kept switching back to black. Then it finally stayed for all of a minute, and now it keeps returning to yellow.

Might my preferences file be corrupted or something? How can I fix this?

(Search box highlighter seems to be working fine.)

Thank you for your assistance!

Could you list the exact steps I need to see the Find/highlight problem? It sounds like a bug, but I’d need to reproduce it for myself to test it out.
Thanks and all the best,

I became aware of it starting after I:

  • Selected some text and set the arbitrary color to black to black out some text.
  • Started fighting with the highlighter-changing-its-own-color-on-me.
  • Command-F searched for “eight” in a document; at first, even though I’d changed the HL color to green, it started doing it in black. Now it’s insisting on yellow.
  • I opened another project to make sure the command-F highlighter thing wasn’t just the one project, and it isn’t. I also checked the “search” box, and that works fine. In pink.

I’m away from my Mac atm, and I can’t exactly try to replicate it until I’ve fixed it. Sorry that I can’t be more detailed. :confused:

Thanks. Found and fixed for the next update!
All the best,

Hello everyone at LL!

Even though this post is 12 yrs old, I happen to have the same problem. After updating to Mac OS Big Sur and also updating Scrivener to the latest version, my search window does pretty much what Carradee reported 12 yrs ago: When I search for a term and hit Enter (which closes the search window), the corresponding term is highlighted in system color. But when I move on (e.g. by hitting arrow keys), the highlighting remains, now black. Just as if I had used the highlighting button in the font size / bold / italic etc. bar. So after each earch, I have to hit Cmd+Z to undo the highlighting…

When I use the search without hitting Enter but using the mouse and the next/previous buttons, the problem does not occur. But that would be a rather annoying workaround, as it requires too many clicks to get back to the text.

A bug again? Or can I change this in the search/highlight options? I have never changed anything there, and would not even know where to go…

Thanks!! Sebastian