Highlighting keyboard shortcuts in 2.0

I’m trying 2.0 and already enjoying it a lot. Much to explore! I don’t know if it’s an oversight but one change I’ve noticed is that the keyboard shortcuts for specific highlight colours (e.g. ctrl+cmd+2 for orange) have disappeared. It’s easy enough to restore them via the Services preferences but just wanted to point it out.

BTW, I do like that we have heaps more highlighter pens in our pencil case now!

No, not an oversight, the shortcuts have been repurposed seeing as there is now a button in the format bar and you can have as many colours as you want - so creating your own shortcuts for them is the way to go.

Fair enough.

For those who don’t know, creating your own keyboard shortcuts on the Mac is easy via the Services menu. In Scrivener, go to Scrivener > Services > Services Preferences…

Select ‘Application Shortcuts’ and click the small ‘+’ button, then enter the details, and your chosen shortcut, in the appropriate fields.

Obviously you need to make sure you create unique shortcuts that won’t conflict with other application and global shortcuts that already exist.

In your first screenshot, which shows the various marker colors under the Scrivener NaNo app–Do those generate automatically? I had to add the Scrivener App to the Application Shortcuts window for it to show at all, and add the specific colors one by one.

That’s how the interface works, bargonzo, you aren’t missing anything. Apple’s override system is purely an “overlay”. You have to add overrides for each item individually, and since it isn’t aware of the application’s menus at that level, you have to type them all in by hand.

Thanks, Amber–

Since you have to type in the commands exactly, where does one find a list of available commands?

(P.S. I used to live in Portland and hope someday to be able to return. I miss Oregon terribly!)

Simply by browsing the menus. :slight_smile: Find what you want to change; type in the menu name precisely (including the dots, if it has them).

It’s cold and rainy today in Portland. But that’s what I like about it.

Yes those dots are important!!

And just to emphasise something about the syntax for these commands that seemed a bit counter-intuitive to me.

If a menu option is found several levels down

eg Edit > Insert > Image From File…

one ignores everything except the final option wording, and types that into the box - in this case:

Image From File…

If two options in the Application have the exact same wording, the system will execute the first that is found when the system scans the menu.


Thanks to you both for that information…

I’m trying out Scrivener right now and the lack of Keyboard shortcuts is really bugging me. I followed directions above, but don’t have a “services” selection available to me in preferences.

I’m running Mac. 10.5.8 and Scivener 2.0b

Is this a Snow Leopard 10.6 thing?


?? Scrivener has way more shortcuts than the average application on the Mac, and puts nearly everything (actually, I think at this point, “everything” without the nearly is accurate) in a menu somewhere so you can customise it. There are so many shortcuts that is is quite difficult to come up with new ones for new features. Keith and I have bumbled over shortcut ideas for days trying to come up with good solutions.

Which preference pane are you in? System Preferences : Keyboard, right? There should be a whole section devoted to services, there, in Snow Leopard.

I’ve followed these instructions to the letter, and CANNOT get this to work. They keyboard shortcuts I create do nothing. I’ve played with a huge variety of commands to see what’s going wrong and nothing works.

I’ve always been able to create shortcuts successfully in other apps, and I’ve retested those to make sure they still work. So I’m (probably) not a complete numpty. Yet for Scriv, I can’t get the keyboard shortcuts to do anything.

I’m trying to create marker highlights, as shown in the example used in this thread, but neither the standard commands (eg ‘Yellow Marker’) or my own customised colours will run from a shortcut. Has anyone else experienced this? Or does anyone have any suggestions why this might be the case?

(Scriv 2.0.1 / OS 10.6.5)

Actually, adding keyboard shortcuts to the highlight menu won’t work very well because it is dynamically-generated, meaning that it may not exist when you hit the keyboard shortcut and so there will be no menu matching the shortcut for OS X to find. Menus that can change depending on user or project settings only get created when you open the menu, so custom shortcuts only work on them if the menu has already been opened.


Is there a specific way this will get messed up? My highlighter shortcuts work fine even on highlights that I’ve renamed or new colors I’ve created myself. Is the expectation that they’ll fritz if I add new colors or rename something?

Actually, discard what I said before, I was completely wrong. Highlighter keyboard shortcuts should work. The highlight menu is dynamic, but it’s only the dynamic menus that take a long time to build that can have problems with keyboard shortcuts. Essentially, in Cocoa, if you hit a keyboard shortcut, then by default OS X will scour through all the menu items looking for a match, building any dynamic menus as necessary. For those dynamic menus that take ages to build - such as the ones for Scrivener links, where you might have hundreds of files in the project that need associated menu items - it’s not desirable to have OS X look through them, so I have some menus that are excluded from the keyboard shortcut search. The highlight menu isn’t one of them - I got that mixed up.

So… Yes, keyboard shortcuts should work fine.

Simon T - what keyboard shortcuts did you try to assign? If they are assigned to another menu item somewhere, that may be the problem.


Just a quick aside: If you are heavily customizing keyboard shortcuts for lots of applications you might find KeyCue useful:



I’ve tried to assign the five ‘standard’ highlights available in Scrivener, eg:

Yellow Marker
Pink Marker
Green Marker

I tried to use the shortcuts:
contrl - alt - command - Y
contrl - alt - command - P
contrl - alt - command - G

I really want to be able to use these, as another app I use a lot (Bean, a simple word processor) uses these same commands.

I tried altering the shortcuts as well, by using shift instead of control, but still it wouldn’t work. Seems odd to me.

Yes…I just tested and I can assign those shortcuts. Hmm. When you set it, absolutely nothing happens? The shortcuts don’t appear in the Format>Highlight menu and typing them does nothing? It is the case that I have to use the personalized shortcut to switch the color and turn on the highlight but the default “highlight on/off” shortcut to stop highlighting–the customized shortcut just changes the color and sets it “on.” But it doesn’t sound like that’s your problem.

All I can think then is back to what Keith said, maybe you have some kind of system shortcuts with those keys and it’s overriding the application-specific settings? Try just setting one temporarily to cmd-V and see if that sticks. (Obviously you’ll want to delete it after you’re done, but just as a test, it ought to stick and override the usual paste command.) If that one works, I think your other shortcuts must just be in use by something higher up the food chain. Although you’d think you’d notice when you typed them and something happened. Hm. :confused:

I’m also having a quirk with keyboard shortcuts. I set up alt-B in Prefs to for Body Text formatting, and all I get is what’s presumably the Apple designated character for alt-B: “∫”. The shortcut appears on both the formatting submenu and the dropdown in the formatting bar, so it’s clearly being recognised at some level. It just doesn’t alter the text. It’s not as though it’s picking up another menu item either because it’s inserting the character.

Any ideas?

OK, I have found out why my keyboard shortcuts weren’t working. I’ll explain in case anyone else has the same problem.

Looking in the Keyboard shortcuts area, I realised it was using the logo of Scriv 1, not the new logo of Scriv 2. That got me thinking, and I remembered not deleting Scriv 1. I had kept it in a subfolder of my Applications folder, just in case. (What do mean anal retentive! I resent that).

So, I took a deep breath and removed Scriv 1. Having done so, the Keyboard shortcuts got very confused, and called the Scrivener shortcuts “com.lieratureandlatte.scrivener” - a name clearly pulled from a preference file. So I deleted all shortcuts for this and started over. I sent the keyboard shortcuts thingy off to find Scriv 2 in my applications folder, and then set about recreating the shortcuts.

They now work!

Long and the short of it - if you have both Scriv 1 and 2 in your apps folder, this might confuse the heck out of the keyboard shortcuts functionality. Take the plunge. Remove Scriv 1.