How compile custom metadata?

When I look at my draft folder in the outline mode, I have one column with title and synopsis for each scene. I also have one custom metadata column, “Intent”, where I for each scene summarise its function in the script.

I know that I can compile a document with all titles and synopses. But reading the manual and forum I’ve found no way to for each scene also include also the custom metadata, the “intent”. Is there a way to do this?


If you check the Meta-Data box in the File -> Compile -> Formatting pane, does that do what you want?

If not, then your best bet would be to use the Synopsis or the Document Notes to store this information instead.


Thanks Katherine!

Checking the Meta-Data box helped (I actually tried that before, but clicked the check boxes at the wrong level :blush: ). It does what I want. On one level. Problem is that it litter the document with a lot of information that I don’t want, e.g.:

Created: 17 October 2013, 10:13
Modified: 10 October 2015, 12:32
Status: No Status
Label: No Label

I can imagine that I at some time or other would be interested in having status or label included in the document. For what I want to achieve right now, though (as long as there is no way to pick and chose what meta-datas goes into the compilation?), I’ll go with your second suggestion. i.e., I’ll move my comments to document notes (the synopsis is already used for the summary of the scene). Thanks again, Katherine.

You can compile specific meta-data by inserting the appropriate placeholder tag into the compiling text, e.g. you could add it to the title suffix in compile. To compile the custom meta-data “Intent”, use <$custom:Intent>.

(The full list of placeholders is under Help > Placeholder Tags List.)

Thanks Jennifer,

but still not able to get what I want. For some reason the meta-data comes out bold and before the synopsis, instead of after, where I want it. Best, but not perfect, seem to be to write the text in Document Notes or check the Meta-Data box in the Compile>Formatting pane (and accept the litter). But, whatever, it’s nothing I lose sleep over. Love your software.

Where are you adding it? It should use whatever formatting you apply to the placeholder tag, so if you’re adding it as part of the title prefix or suffix, after you’ve added it be sure to click into the preview text to select it, then use the format bar to style it however you want.

EDIT: Sorry, I missed the bit about placement. To force the order that you want, use a placeholder tag for the synopsis as well, instead of ticking the “synopsis” column for the item. So, using the title suffix example, add it this way:


That would then come out with the title first (if you’re compiling a title, or if there’s a prefix), then the synopsis, then your “intent” custom meta-data, and then be followed by whatever other items you have ticked in the compile formatting table. Be sure to start the suffix with a carriage return if you are compiling a title or prefix, so that the text doesn’t run together.

The one catch here is that your synopsis and “intent” meta-data will have to both use the same formatting.

thanks for your patience. Now it all works fine. So I’m afraid I’ll have to stop fiddling with the settings and start thinking about the content. Tough :confused:

Hey now! Let’s not be hasty. I’m sure there is some other fiddly, esoteric feature of Scrivener that you might need to puzzle out; some as-yet unrealized need you have that Scrivener doesn’t fulfill with its basic settings that you could spend hours, nay days adjusting and tweaking.

Don’t give up hope or procrastination. We’re here for you.

Wait, that’s a thing? :open_mouth: :open_mouth: :open_mouth:

How on earth did I miss that? :blush:

That is a major revelation, thanks MM.

…now I have some workflow adjustments to make. :smiley:

Thanks, Robert! You give me hope :laughing:

I must be missing some fundamental step because when I set this up all I get printed on the documents is <$custom:Element> no matter where I place it.

Here is what I’m doing:

I created a custom meta-data named ‘Element’ and I checked the wrap-text checkbox.
I added the custom meda-data data into the field in the custom meta-data panel for each of my documents.
I added <$custom:Element> in the Page Settings in compile.
I added <$custom:Element> in the formatting option in compile.
And I placed <$custom:Element> randomly inside the text of the document itself.

All I get is a printed version of <$custom:Element> on each page.

Any suggestions?