How could I get the cursor to be shown in the right position?

How could I get the cursor to be shown in the right position (not with over one half outside of the lilne?)?

And the same for inline annotations?

Essentially: don’t write using custom line-height settings. It’s a deep flaw in the text engine that they have yet to fix.

I understand in your case, with scriptwriting mode being used, you may not have that choice as line-height settings are part of what defines a script’s formal look.

Consider though, if your workflow does involve compiling to FDX, and then finishing off the work in another tool, that you could adopt a “writer-only” script setup that avoids these line height settings, and then wait until post-compile to reformat the elements to standard.

Essentially: don’t write using custom line-height settings.

That is an excerpt of the screenplay script. So that means do not use that script? So how then should one write a script?

Consider though, if your workflow does involve compiling to FDX, and then finishing off the work in another tool, that you could adopt a “writer-only” script setup that avoids these line height settings, and then wait until post-compile to reformat the elements to standard.

Oops, this seems to be the answer already. So then why not write the script right away with Final Draft?

that you could adopt a “writer-only” script setup that avoids these line height settings, and then wait until post-compile to reformat the elements to standard.

Sorry, I do not understand what that means. What would I have to do? Sounds quite elaborate, laborious.

Sorry, I do not understand what that means. What would I have to do? Sounds quite elaborate, laborious.

I don’t know how to use Final Draft (or whatever you use). Surely it’s a simple matter to apply formatting settings to the text in a global, centralised fashion, based on what you have assigned to elements. I’m merely speaking of the equivalent of editing your script settings in Scrivener, or switching between script formats and having it perform element conversion.

Biff,
I went back and looked at the earlier conversation you and I had about using inline annotations for alternative text lines. By your screenshots from back then, I can tell that you did not have this issue.
What did you change since ?

Please name everything you can remember ; however insignificant it may seem.

By the way, I ran into a bug or two when modifying settings using the Script Settings pane in Scrivener. Ultimately I found it easier to just switch off the line-height code in the XML file itself. Here is a screenplay format file you can use:

screenplay-single_spaced.zip (1.2 KB)

To import into your project, use Format ▸ Scriptwriting ▸ Script Settings..., and use the “Manage” button in the lower left.

Now as for the second matter, of changing things back after compiling, I forgot there is a setting that can help with this:

  1. Open File ▸ Compile...
  2. Double-click on “Script or Screenplay” compile format in the left sidebar to edit it.
  3. In the Script Settings pane, select Use default Final Draft screenplay elements.

It will now ignore your custom script settings and output standard results, liberating you to do most anything you’d like, aesthetically.

Hello Vincent,

I did not change anything (intentionally). But I actually would think, nothing has changed, the cursor’s position didn’t change and the position of the inline notation frame / format may be depends on the kind of fonts, style, etc.

To import into your project, use Format ▸ Scriptwriting ▸ Script Settings…, and use the “Manage” button in the lower left.

Many thanks. I have to unzip it before, I assume. By import is meant "Load from file…? Then click OK? Nothing happens, I would think, no changes. Anything else to do? Or differently? I have to do it for each project? Or only once? Restarting does not appear to help.

Ok…
With any luck, you might still have a snapshot of this (or an old backup of the project) and be able to rollback and have a look :

image

See how the first inline annotation is fine, where the second is not…
(My bad, I thought all was fine, but looking closer, it is not. Sorry.)

Can you go in your project and see what is the formatting difference between those two paragraphs ?

– Did you modify stuff like the font and/or font size, line spacing (anything related to formatting) using the format bar ? (Or using any other menu/panel than those in my two below screenshots ?)

– Are they different script elements ? (Dialogue, action etc.)

Look here (for the corresponding script elements) :
image

2022-03-09 14_25_09-Window

2022-03-09 14_25_35-Window

Or, meanwhile, can you post the same two screenshots as I just did for one of your presently problematic paragraphs ? Thank you.

I am sure, I still have it, but I do not have any idea in which project it is, I found a test here, where I tried to add that script above (may be it is effecting already) and I just tried a litte, “General Text”:

Can the Gerneral Text be left out for compiling?

No no, no reason at all to say sorry, glad about your great help.

And this is “Dialog”:

I somehow cannot cope with the wrong cursor position at all. Always have to click around / concentrate to hit the line respectively somewhere below the line. I am wondering how others obviously can cope with such. Very strange. May be I am to effeminate or so.

Yes, of course:

I do not know if that script also would effect the lines being already written. I assume, it would.

If that is just a test project (containing nothing personal or sensitive of yours),

can you
– do a save as,

– then strip down that new version of your test project to one or two problematic documents (preferably those two from which you just produced your screenshots),

– do a Zipped backup of the stripped down project

– and upload it here ?

I’ll have a close look, hands on.

P.S. Now that you have posted new screenshots, I would actually have wanted 4 screenshots from you :
– 2 of General text script settings
– 2 of Dialogue script settings
→ To match what I see on screen. But it is so all over the place, that I would much prefer if you could upload the project.

This is from your own screenshot :

Inked2022-03-09 15_47_27-Window_LI

And it looks wrong to me, conflictual perhaps (i am not sure), but you there have the “space before” specified twice. 9.0pt & 12.00pt just below. (??)

Try changing the first “spacing” that is currently at [1.0x 9.0/0.0] to just [1.0x] from the dropdown list. Then type a few lines in the editor. Is it better ?

I was just informed that this is actually a bug. So, there is nothing much I can do that AmberV hasn’t already done.
If changing “spacing” from [1.0x 9.0/0.0] to [1.0x] from the dropdown list doesn’t fix your issue,
use her solution :
(It is a screenplay template that she manually fixed. Use that for your project(s) )

When the provided XML file is loaded into the project via the Script Settings pane, with “Load from file…”, and you click the OK button, it should ask in a subsequent dialogue how you want to have existing text converted to the new settings. Make sure the elements line up in the two columns (they should if you’re going from screenplay stock to screenplay) and click OK.

This doesn’t impact General Text as that is not a real element with settings.

These settings are very confusing, and somewhat ignored internally. There are supposed to be two simple settings in this dialogue box:

  • Spacing: with four possible settings: 1, 1.2, 1.5 and 2. Simple. No complex settings, no paragraph padding, etc.
  • Spacing Before: four possible settings: 0, 1, 2, 3. Nobody should be asked to calculate how many points it takes to add two lines of space, derived from the font size they use.

I can’t really explain how the five separate available settings only impact these two fields, nor do I care to test it too deeply, since none of this is supposed to be here in the GUI anyway.

Oops, OK, very strange.

Sounds quite complicated somehow (for me). And so the cursor position would not change as well, I assume.

OK, well, not that bad, so I will just go on using Final Draft for scripts (and go back to Word or OpenOffice or such for other purposes. Or is there anything else to recommend?). It is much easier for me, so I simply can wirte (well, if I had ideas at least).

Very sorry for having wasted your time. And thank you very, very much for your great help.

It’s OK. No time was wasted here. :wink:
But just to be clear, all you have to do now is to download the script format and follow AmberV’s short and simple instructions.
It should fix both the cursor and the inline annotations.

The “they” in this case being Qt, correct?

But just to be clear, all you have to do now is to download the script format and follow AmberV’s short and simple instructions.
It should fix both the cursor and the inline annotations.

Yes yes, but I didn’t get it to work (tried to explain above), just tried it again to make sure. Nothing changes (as far as I can see, notice). And there are some other (big) problems / bugs or whatever it is I have. So it does not appear to make sense for me to go on using it finally, I guess.

Thank you very much anyway, very happy about your help.

As I understand it the problem originates in the Qt text engine, but they (the Scrivener programmers) feel there is a chance it can be fixed, but that it’s not trivial to do so. We’ve been aware of it since day one—and pushed hard to have it fixed before 3.0.0, but it’s not an easy one.

Thankfully only a small fraction of people encounter it since most forms of line-spacing formatting do not trigger it badly. It’s this “Exactly: 12pt” style format that screenplays use that is particularly problematic.

1 Like