How did I do this? I want to do it again, but I can't figure it out

I looked at an old item I created in the Research section of a Scrivener document. What I seemed to have done is import a number of another person’s Tweets, with hyperlinks and all. I have attached an image and I hope you can tell me how I might have done this or tell me how you do it.

Image is attached

Copy and paste is what it looks like to me. – Katherine

Unfortunately, a simple cut and paste strips the hyperlinks, so it’s not that, but thanks anyway.

Copy and paste from Twitter.com preserved hyperlinks when I tried it. What version of Scrivener do you have?

Katherine

Hi Katherine,

I’m running 3.0.1 (966)

Katherine,

Would you be so kind as to go to AllMyTweets (allmytweets.net) and see if you can grab 40-50 tweets and try to do a cut and paste and see if your paste retains its links?

Thanks

Works fine.

3.0.1 is a few versions back. The current version is 3.1.2, I’m not aware of any bugs related to this specific issue, but I’d definitely recommend upgrading.

Are you using a straight paste, not “paste and match style?”

What happens if you paste into TextEdit?

What browser are you using? Do the results change if you use a different one?

Katherine

Hi Katherine,

  1. I upgraded to 3.1.12 (10882)
  2. I am using a straight past, not ‘paste and match style’
  3. Same results when I used TextEdit, no links carry over.

Very strange, and this is a facility I really need for a current project.

Thanks for trying, and if there’s any way you can recommend anything else, I’d be most appreciative.

Terrance

Yes, in the other thread that this problem is posted in, we learned that TromboneAl’s problem turned out to be owing to something his browser (Chrome in that case) was doing.

If you also see it in TextEdit, it’s not a Scrivener problem. It’s either your browser or Mac OS.

Have you tried a different browser?

What version of Mac OS do you have?

Katherine

I’m a Chrome user but tested it with Brave and Safari and got same results.

I"m running Mojave 10.14.4, but latest is .5.

Maybe I’ll just have to do the manual URL paste if I can’t find a solution.

Thanks for trying.

Terrance

See AmberV’s response in the other thread. Especially since it’s system wide, clipboard managers are likely suspects.

Katherine

Hi Katherine,
I seem to have lost the flow. Can you point to or somehow give me more direct on Amber’s other thread?

Thanks

No doubt Katherine is referring to this thread where you posted the very same question as here:

[url=https://forum.literatureandlatte.com/t/pasting-a-url-without-changing-formatting/45839/10]

gr