How do I clear formatting (use styles)?

I am a new user of Scrivener and spend the last two days learning more and more about the tool.

I am not the average computer user, in fact I was a a software developer, but I think that Scrivener could be used to write technical software documentation as well.

Still there is something I was not able to understand even after doing, a lot of, research on the net: how do I reset the formatting? (clear formatting).

Here is the use case: you copy some text from another place (like webpage or word document) and you paste it to Scrivener. My assumption would be that the application will recognize some of the formatting and replace it with one of the default styles (preset) and drop other. I tested both simple paste and past-and-match-style without success.

Also, I tried to select a section of text having a not desired formatting and tried to clear it to “defaults”, but this seams to be impossible or at least is very well hidden.

I am not sure if I was clear enough but I was to use only standar styles/preset so I can change the formatting for the entire document whenever I want. In fact I would like to “bad” the usage of custom font and font size if possible, and even remove it from the format bar. BTW, the “presets” option should be the first one, not the last one, to make it visible even when the application window is smaller.

How can I achieve this?

It sounds as though you are looking for Documents > Convert > Formatting to Default Text Style. This will reset all the formatting in a document to use the formatting you have set up in the preferences, while maintaining bold, italics and suchlike.

Thanks, this seams to solve most of my problem. I still see some paragraph with different line spacing that is not reset by this option.

It should be - did you make sure that all the “Convert Format Options” were unticked in the sheet that pops down before you converted?
All the best,
Keith

And if that doesn’t work, check if you have superscripted or subscripted characters in the paragraphs that aren’t converting–they can cause odd line spacing. You can select the paragraph and choose Format>Font>Baseline>Use Default to reset it.

I do not have subscript/superscript items and using this option doesn’t help resetting the line spacing to default (something that looks like 1.5).

If I go to Format > Text > Spacing… and I select a line spacing of 1.5 the bad spacing is resolved.

Still, I do not consider these operatios a valid clean-formatting option, they require too much manual work.

As Keith said, the Convert to Default should have fixed the spacing, if it was something that could be resolved by your manually adjusting it as you ended up doing, so it’s odd that it didn’t work. Did you double-check that “preserve line spacing” wasn’t checked in the Convert Format Options that came up when you selected Convert>Formatting to Default Text Style?

I forgot to mention that inside the Convert Format window I can check only the first two checkboxes, the others are disabled, including the one with line spacing.

You want to uncheck them all. If “convert font only” is checked, it disables the other options except “preserve font size” (since they’re unnecessary, as only the font will be changed). In your case, you want to convert everything, not just the font, so don’t select that first option–and then don’t select the last one either, since you don’t want to preserve the current line spacing, you want to convert it to your defaults as defined in Preferences.

As long as you have the correct options checked, no manual work is needed other than choosing a single menu option.

I’m having similar issues and I’m trying to determine if I’m up against user stupidity, poor application design, or a combination of bugs.

My situation:
I have a paragraph with mixed formatting and I want it to be set to the default paragraph formatting.

My previous attempts:

  • I find no “Clear formatting” command that applies to selected text
  • The Document -> convert command applies to the whole document
  • I find no “Paste as plain text” command
  • The Document -> convert method still leaves me with a mix of bold, underline and italic, although the font and font size were stripped correctly
  • Using the “Preset…” button and selecting “Body” produced a result different from what I had typed in by hand.

In short, I could not manage to start with a paragraph that contained unwanted formatting and end up with one that appeared as if I had simply typed the text.

My recommendation is to implement a “Paste as plain text” command that parses the clipboard for text and bypasses any and all markup, effectively mimicking the process of typing the text at the location of the cursor.

It also seems like selecting “body” from the presets should do the same thing.

Try Edit/Paste and Match Style. This is the Mac OS X standard plain text pasting and has a keyboard shortcut linked to it too.

It is just the strength of the Convert to command not to flatten any italics etc. as applying of a style would do. You might create a style a. k. a. preset—if you haven’t done so already—containing the font, font size, borders, and line spacing but no such things as italics and afterwards you could apply it to any part of your text you want.

I’ve made significant progress since my post.

I had not picked up on the “Paste and match style” because I had deleted all text and the cursor insertion point still contained some font size information, etc. The command does do exactly what I would hope in the case where you have not buggered everything up, which I only did to play around with the program. In the real world, I think there would be no issue.

I also solved my other issue, which was the discrepancy between “document default” and the “body” preset. I ended up opening a new, unsullied document and typed a word, then used that word/paragraph to redefine the “body” preset. It seems natural to me that “body” and “default” should be the same, but I suppose there are other use cases.

Thanks for the post.

Can’t we have a clean-formatting option eventual one that can be run over several selected documents?

I am doing a lot of copy and paste from different sources and once the formatting (especially font) is modified it is a nightmare to repair it.

BTW, I observed the the toolbar is disabled if you try to select several documents in Binder, sad, it could be a way to “reset” the font.

The toolbar affects text only. Just load all the documents you want to affect in scrivenings, select all, and clear the font that way.

Hmm, maybe this will help?

Select the documents in Binder, which puts them as a continuous feed of documents in your editor context. Select All, then apply the Body style. That will clean your formatting… I believe it leaves italics (maybe bold) in place. But, it should impose uniformity on your document—which I gather is the goal.

The “Body” preset only affects paragraph formatting, so character attributes like bold and italic will be left untouched. The other way to do this is just to select all the documents you want to change and then use the Documents>Convert>Formatting to Default Text Style, which will bring the formatting in sync with your default settings in the preferences and will give you a list of options for any parts of the formatting you want not to convert like alignment or font size. (This likewise won’t touch character attributes.)

Of course if you want formatting that isn’t the same as your defaults or if you do want to override character attributes, then using a preset for this, applied to all text in a Scrivenings session, is a great option and you can create your own or modify an existing one to get exactly what you want.

Another option (that I use a lot) would be to use the Scrivener service ‘Scrivener: Make new clipping (Unformatted)’. It’s great for research stuff since you can keep snipping away at bits of something as you read it and then you have a collection of unformatted notes at the end in your Clippings collection :slight_smile: